Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ddi_fm_init(9f) [opensolaris man page]

ddi_fm_init(9F) 					   Kernel Functions for Drivers 					   ddi_fm_init(9F)

NAME
ddi_fm_init, ddi_fm_fini, ddi_fm_capable - initialize and get the FM capabilities for a device instance SYNOPSIS
#include <sys/ddifm.h> void ddi_fm_init(dev_info_t *dip, int *fm_capability, ddi_iblock_cookie_t *ibcp); void ddi_fm_fini(dev_info_t *dip); int ddi_fm_capable(dev_info_t *dip, int *fm_capability); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) PARAMETERS
ddi_fm_init() dip Pointer to the dev_info structure fm_capability Fault Management capability bit mask ibcp Pointer to where the interrupt block cookie should be returned. DESCRIPTION
A device driver can declare its fault management capabilities to the I/O Fault Management framework by calling ddi_fm_init(). The ddi_fm_init() function allocates and initializes resources according to the bitwise-inclusive-OR of the fault management capabilities, described in the following and supported by the driver's immediate nexus parent. DDI_FM_NOT_CAPABLE The driver does not support any FMA features. This is the default value assigned to device drivers. DDI_FM_EREPORT_CAPABLE The driver generates FMA protocol error events (ereports) upon the detection of an error condition. DDI_FM_ACCCHK_CAPABLE The driver checks for errors upon the completion of one or more access I/O transactions. DDI_FM_DMACHK_CAPABLE The driver checks for errors upon the completion of one or more DMA I/O transactions. DDI_FM_ERRCB_CAPABLE The driver is capable of error handler callback registration. If the parent nexus is not capable of supporting any one of the requested capabilities, the associated bit will not be set and returned as such to the driver. Before returning from ddi_fm_init(), the I/O Fault Management framework creates a set of fault management capability properties: fm-ereport-capable, fm-errcb-capable, fm-accchk-capable, and fm-dmachk-capable. The current supported fault management capabil- ity levels are observable via prtconf(1M). A driver can support the administrative selection of fault management capabilities by exporting and setting a fault management capability level property in its driver.conf(4) file to the values described above. The fm_capable properties must be set and read prior to calling ddi_fm_init() with the desired capability list. ddi_fm_fini() This function cleans up resources allocated to support fault management for the dip structure. ddi_fm_capable() This function returns the capability bit mask currently set for the dip structure. CONTEXT
These functions can be called from kernel context in a driver attach(9E) or detach(9E) operation. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
prtconf(1M), driver.conf(4), attributes(5), attach(9E), detach(9E) Writing Device Drivers SunOS 5.11 14 May 2007 ddi_fm_init(9F)

Check Out this Related Man Page

pci_report_pmcap(9F)					   Kernel Functions for Drivers 				      pci_report_pmcap(9F)

NAME
pci_report_pmcap - Report Power Management capability of a PCI device SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> int pci_report_pmcap(dev_info_t *dip, int cap, void *arg); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) PARAMETERS
dip Pointer to the device's dev_info structure cap Power management capability arg Argument for the capability DESCRIPTION
Some PCI devices provide power management capabilities in addition to those provided by the PCI Power Management Specification. The pci_report_pmcap() function reports those Power Management capabilities of the PCI device to the framework. Framework supports dynamic changing of the capability by allowing pci_report_pmcap() to be called multiple times. Following are the supported capabilities as indi- cated by the cap: PCI_PM_IDLESPEED -- The PCI_PM_IDLESPEED value indicates the lowest PCI clock speed that a device can tolerate when idle, and is applica- ble only to 33 MHz PCI bus. arg represents the lowest possible idle speed in KHz (1 KHz is 1000 Hz). The integer value representing the speed should be cast to (void *)before passing as arg to pci_report_pmcap(). The special values of arg are: PCI_PM_IDLESPEED_ANY The device can tolerate any idle clock speed. PCI_PM_IDLESPEED_NONE The device cannot tolerate slowing down of PCI clock even when idle. If the driver doesn't make this call, PCI_PM_IDLESPEED_NONE is assumed. In this case, one offending device can keep the entire bus from being power managed. RETURN VALUES
The pci_report_pmcap() function returns: DDI_SUCCESS Successful reporting of the capability DDI_FAILURE Failure to report capability because of invalid argument(s) CONTEXT
The pci_report_pmcap() function can be called from user, kernel and interrupt context. EXAMPLES
1. A device driver knows that the device it controls works with any clock between DC and 33 MHz as specified in Section 4.2.3.1: Clock Specification of the PCI Bus Specification Revision 2.1. The device driver makes the following call from its attach(9E): if (pci_report_pmcap(dip, PCI_PM_IDLESPEED, PCI_PM_IDLESPEED_ANY) != DDI_SUCCESS) cmn_err(CE_WARN, "%s%d: pci_report_pmcap failed ", ddi_driver_name(dip), ddi_get_instance(dip)); 2. A device driver controls a 10/100 Mb Ethernet device which runs the device state machine on the chip from the PCI clock. For the device state machine to receive packets at 100 Mb, the PCI clock cannot drop below 4 MHz. The driver makes the following call whenever it negoti- ates a 100 Mb Ethernet connection: if (pci_report_pmcap(dip, PCI_PM_IDLESPEED, (void *)4000) != DDI_SUCCESS) cmn_err(CE_WARN, "%s%d: pci_report_pmcap failed ", ddi_driver_name(dip), ddi_get_instance(dip)); ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
Writing Device Drivers PCI Bus Power Management Interface Specification Version 1.1 PCI Bus Specification Revision 2.1 SunOS 5.11 13 August 1999 pci_report_pmcap(9F)
Man Page