Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

atomic_clear_long_excl(9f) [opensolaris man page]

atomic_bits(9F) 					   Kernel Functions for Drivers 					   atomic_bits(9F)

NAME
atomic_bits, atomic_set_long_excl, atomic_clear_long_excl - atomic set and clear bit operations SYNOPSIS
#include <sys/atomic.h> int atomic_set_long_excl(volatile ulong_t *target, uint_t bit); int atomic_clear_long_excl(volatile ulong_t *target, uint_t bit); DESCRIPTION
The atomic_set_long_excl() and atomic_clear_long_excl() functions perform an exclusive atomic bit set or clear operation on target. The value of bit specifies the number of the bit to be modified within target. Bits are numbered from zero to one less than the maximum number of bits in a long. If the value of bit falls outside of this range, the result of the operation is undefined. RETURN VALUES
The atomic_set_long_excl() and atomic_clear_long_excl() functions return 0 if bit was successfully set or cleared. They return -1 if bit was already set or cleared. ERRORS
No errors are defined. CONTEXT
These functions can be called from user, interrupt, or kernel context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
atomic_add(9F), atomic_and(9F), atomic_cas(9F), atomic_dec(9F), atomic_inc(9F), atomic_or(9F), atomic_swap(9F), membar_ops(9F), attributes(5), atomic_ops(3C) SunOS 5.11 16 Jan 2006 atomic_bits(9F)

Check Out this Related Man Page

atomic_swap(9F) 					   Kernel Functions for Drivers 					   atomic_swap(9F)

NAME
atomic_swap, atomic_swap_8, atomic_swap_uchar, atomic_swap_16, atomic_swap_ushort, atomic_swap_32, atomic_swap_uint, atomic_swap_ulong, atomic_swap_64, atomic_swap_ptr - atomic swap operations SYNOPSIS
#include <sys/atomic.h> uint8_t atomic_swap_8(volatile uint8_t *target, uint8_t newval); uchar_t atomic_swap_uchar(volatile uchar_t *target, uchar_t newval); uint16_t atomic_swap_16(volatile uint16_t *target, uint16_t newval); ushort_t atomic_swap_ushort(volatile ushort_t *target, ushort_t newval); uint32_t atomic_swap_32(volatile uint32_t *target, uint32_t newval); uint_t atomic_swap_uint(volatile uint_t *target, uint_t newval); ulong_t atomic_swap_ulong(volatile ulong_t *target, ulong_t newval); uint64_t atomic_swap_64(volatile uint64_t *target, uint64_t newval); void *atomic_swap_ptr(volatile void *target, void *newval); DESCRIPTION
These functions enable a swap operation to occur atomically. The value stored in target is replaced with newval. The old value is returned by the function. RETURN VALUES
These functions return the old of *target. ERRORS
No errors are defined. CONTEXT
These functions can be called from user, interrupt, or kernel context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
atomic_add(9F), atomic_and(9F), atomic_bits(9F), atomic_dec(9F), atomic_inc(9F), atomic_or(9F), atomic_cas(9F), membar_ops(9F), attributes(5), atomic_ops(3C) SunOS 5.11 16 Jan 2006 atomic_swap(9F)
Man Page