Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

read(9e) [opensolaris man page]

read(9E)							Driver Entry Points							  read(9E)

NAME
read - read data from a device SYNOPSIS
#include <sys/types.h> #include <sys/errno.h> #include <sys/open.h> #include <sys/uio.h> #include <sys/cred.h> #include <sys/ddi.h> #include <sys/sunddi.h> int prefixread(dev_t dev, struct uio *uio_p, cred_t *cred_p); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). This entry point is optional. PARAMETERS
dev Device number. uio_p Pointer to the uio(9S) structure that describes where the data is to be stored in user space. cred_p Pointer to the user credential structure for the I/O transaction. DESCRIPTION
The driver read() routine is called indirectly through cb_ops(9S) by the read(2) system call. The read() routine should check the valid- ity of the minor number component of dev and the user credential structure pointed to by cred_p (if pertinent). The read() routine should supervise the data transfer into the user space described by the uio(9S) structure. RETURN VALUES
The read() routine should return 0 for success, or the appropriate error number. EXAMPLES
Example 1 read() routine using physio() The following is an example of a read() routine using physio(9F) to perform reads from a non-seekable device: static int xxread(dev_t dev, struct uio *uiop, cred_t *credp) { int rval; offset_t off; int instance; xx_t xx; instance = getminor(dev); xx = ddi_get_soft_state(xxstate, instance); if (xx == NULL) return (ENXIO); off = uiop->uio_loffset; rval = physio(xxstrategy, NULL, dev, B_READ, xxmin, uiop); uiop->uio_loffset = off; return (rval); } SEE ALSO
read(2), write(9E), physio(9F), cb_ops(9S), uio(9S) Writing Device Drivers SunOS 5.11 19 Nov 1997 read(9E)

Check Out this Related Man Page

aread(9E)							Driver Entry Points							 aread(9E)

NAME
aread - asynchronous read from a device SYNOPSIS
#include <sys/uio.h> #include <sys/aio_req.h> #include <sys/cred.h> #include <sys/ddi.h> #include <sys/sunddi.h> intprefix aread(dev_t dev, struct aio_req *aio_reqp, cred_t *cred_p); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). This entry point is optional. Drivers that do not support an aread() entry point should use nodev(9F) PARAMETERS
dev Device number. aio_reqp Pointer to the aio_req(9S) structure that describes where the data is to be stored. cred_p Pointer to the credential structure. DESCRIPTION
The driver's aread() routine is called to perform an asynchronous read. getminor(9F) can be used to access the minor number component of the dev argument. aread() may use the credential structure pointed to by cred_p to check for superuser access by calling drv_priv(9F). The aread() routine may also examine the uio(9S) structure through the aio_req structure pointer, aio_reqp. aread() must call aphysio(9F) with the aio_req pointer and a pointer to the driver's strategy(9E) routine. No fields of the uio(9S) structure pointed to by aio_req, other than uio_offset or uio_loffset, may be modified for non-seekable devices. RETURN VALUES
The aread() routine should return 0 for success, or the appropriate error number. CONTEXT
This function is called from user context only. EXAMPLES
Example 1: The following is an example of an aread() routine: static int xxaread(dev_t dev, struct aio_req *aio, cred_t *cred_p) { int instance; struct xxstate *xsp; instance = getminor(dev); xsp = ddi_get_soft_state(statep, instance); /*Verify soft state structure has been allocated */ if (xsp == NULL) return (ENXIO); return (aphysio(xxstrategy, anocancel, dev, B_READ, xxminphys, aio)); } SEE ALSO
read(2), aioread(3AIO), awrite(9E), read(9E), strategy(9E), write(9E), anocancel(9F), aphysio(9F), ddi_get_soft_state(9F), drv_priv(9F), getminor(9F), minphys(9F), nodev(9F), aio_req(9S), cb_ops(9S), uio(9S) Writing Device Drivers BUGS
There is no way other than calling aphysio(9F) to accomplish an asynchronous read. SunOS 5.10 28 Mar 1997 aread(9E)
Man Page