Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

connld(7m) [opensolaris man page]

connld(7M)							  STREAMS Modules							connld(7M)

NAME
connld - line discipline for unique stream connections SYNOPSIS
#include </sys/steam.h> int ioctl(fd,I_PUSH,"connld"); DESCRIPTION
connld is a STREAMS-based module that provides unique connections between server and client processes. It can only be pushed (see streamio(7I)) onto one end of a STREAMS-based pipe that may subsequently be attached to a name in the file system name space with fat- tach(3C). After the pipe end is attached, a new pipe is created internally when an originating process attempts to open(2) or creat(2) the file system name. A file descriptor for one end of the new pipe is packaged into a message identical to that for the ioctl I_SENDFD (see streamio(7I)) and is transmitted along the stream to the server process on the other end. The originating process is blocked until the server responds. The server responds to the I_SENDFD request by accepting the file descriptor through the I_RECVFD ioctl message. When this happens, the file descriptor associated with the other end of the new pipe is transmitted to the originating process as the file descriptor returned from open(2) or creat(2). If the server does not respond to the I_SENDFD request, the stream that the connld module is pushed on becomes uni-directional because the server will not be able to retrieve any data off the stream until the I_RECVFD request is issued. If the server process exits before issuing the I_RECVFD request, the open(2) or the creat(2) invocation will fail and return -1 to the originating process. When the connld module is pushed onto a pipe, it ignores messages going back and forth through the pipe. ERRORS
On success, an open of connld returns 0. On failure, errno is set to the following values: EINVAL A stream onto which connld is being pushed is not a pipe or the pipe does not have a write queue pointer pointing to a stream head read queue. EINVAL The other end of the pipe onto which connld is being pushed is linked under a multiplexor. EPIPE connld is being pushed onto a pipe end whose other end is no longer there. ENOMEM An internal pipe could not be created. ENXIO An M_HANGUP message is at the stream head of the pipe onto which connld is being pushed. EAGAIN Internal data structures could not be allocated. ENFILE A file table entry could not be allocated. SEE ALSO
creat(2), open(2), fattach(3C), streamio(7I) STREAMS Programming Guide SunOS 5.11 3 May 2004 connld(7M)

Check Out this Related Man Page

getpeerucred(3C)					   Standard C Library Functions 					  getpeerucred(3C)

NAME
getpeerucred - get connected socket/STREAM peer's credentials SYNOPSIS
#include <ucred.h> int getpeerucred(int fd, ucred_t **ucred); DESCRIPTION
The getpeerucred() function returns the credentials of the peer endpoint of a connection-oriented socket (SOCK_STREAM) or STREAM fd at the time the endpoint was created or the connection was established. A process that initiates a connection retrieves the credentials of its peer at the time the peer's endpoint was created. A process that listens for connections retrieves the credentials of the peer at the time the peer initiated the connection. When successful, getpeerucred() stores the pointer to a freshly allocated ucred_t in the memory location pointed to by the ucred argument if that memory location contains the null pointer. If the memory location is non-null, it will reuse the existing ucred_t. When ucred is no longer needed, a credential allocated by getpeerucred() should be freed with ucred_free(3C). It is possible that all fields of the ucred_t are not available to for all peer endpoints and all callers. RETURN VALUES
Upon successful completion, getpeerucred() returns 0. Otherwise, it returns -1 and errno is set to indicate the error. ERRORS
The getpeerucred() function will fail if: EAGAIN There is not enough memory available to allocate sufficient memory to hold the user credential. The application can try again later. EBADF The fd argument is not a valid file descriptor. EFAULT The pointer location pointed to by the ucred_t ** argument points to an invalid, non-null address. EINVAL The socket is connected but the peer credentials are unknown. ENOMEM The physical limits of the system are exceeded by the memory allocation needed to hold the user credential. ENOTCONN The socket or STREAM is not connected or the STREAM's peer is unknown. ENOTSUP This operation is not supported on this file descriptor. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Evolving | +-----------------------------+-----------------------------+ |MT-Level |MT-Safe | +-----------------------------+-----------------------------+ SEE ALSO
door_ucred(3DOOR), ucred_get(3C), attributes(5), connld(7M) NOTES
The system currently supports both sides of connection endpoints for local AF_UNIX, AF_INET, and AF_INET6 sockets, /dev/tcp, /dev/ticots, and /dev/ticotsord XTI/TLI connections, and pipe file descriptors sent using I_SENDFD as a result of the open of a named pipe with the "connld" module pushed. SunOS 5.10 26 May 2004 getpeerucred(3C)
Man Page