Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

udp(4) [opendarwin man page]

UDP(4)							   BSD Kernel Interfaces Manual 						    UDP(4)

NAME
udp -- Internet User Datagram Protocol SYNOPSIS
#include <sys/socket.h> #include <netinet/in.h> int socket(AF_INET, SOCK_DGRAM, 0); DESCRIPTION
UDP is a simple, unreliable datagram protocol which is used to support the SOCK_DGRAM abstraction for the Internet protocol family. UDP sockets are connectionless, and are normally used with the sendto and recvfrom calls, though the connect(2) call may also be used to fix the destination for future packets (in which case the recv(2) or read(2) and send(2) or write(2) system calls may be used). UDP address formats are identical to those used by TCP. In particular UDP provides a port identifier in addition to the normal Internet address format. Note that the UDP port space is separate from the TCP port space (i.e. a UDP port may not be ``connected'' to a TCP port). In addition broadcast packets may be sent (assuming the underlying network supports this) by using a reserved ``broadcast address''; this address is network interface dependent. Options at the IP transport level may be used with UDP; see ip(4). DIAGNOSTICS
A socket operation may fail with one of the following errors returned: [EISCONN] when trying to establish a connection on a socket which already has one, or when trying to send a datagram with the destina- tion address specified and the socket is already connected; [ENOTCONN] when trying to send a datagram, but no destination address is specified, and the socket hasn't been connected; [ENOBUFS] when the system runs out of memory for an internal data structure; [EADDRINUSE] when an attempt is made to create a socket with a port which has already been allocated; [EADDRNOTAVAIL] when an attempt is made to create a socket with a network address for which no network interface exists. SEE ALSO
getsockopt(2), recv(2), send(2), socket(2), intro(4), inet(4), ip(4) HISTORY
The udp protocol appeared in 4.2BSD. 4.2 Berkeley Distribution June 5, 1993 4.2 Berkeley Distribution

Check Out this Related Man Page

UDP(7P) 																   UDP(7P)

NAME
UDP - Internet User Datagram Protocol SYNOPSIS
DESCRIPTION
UDP is a simple, unreliable datagram protocol used to support the socket type for the internet protocol family. UDP sockets are connec- tionless, and are normally used with the and calls (see send(2) and recv(2). The call can also be used to simulate a connection (see con- nect(2). When used in this manner, it fixes the destination for future transmitted packets (in which case the or system calls can be used), as well as designating the source from which packets are received. The and calls can be used at any time if the source of the mes- sage is unimportant. UDP address formats are identical to those used by TCP. In particular, UDP requires a port identifier in addition to the normal Internet address format. Note that the UDP port domain is separate from the TCP port domain (in other words, a UDP port cannot be connected to a TCP port). The default send buffer size for UDP sockets is 65535 bytes. The default receive buffer size for UDP sockets is 2147483647 bytes. The send and receive buffer sizes for UDP sockets can be set by using the and options of the system call or the and options of the system call. The maximum size for these buffers is 2147483647 bytes. The maximum receive buffer size may be lowered using the parameter The maximum message size for a UDP datagram socket is limited by the lesser of the maximum size of an IP datagram and the size of the UDP datagram socket buffer. The maximum size of an IP datagram limits the maximum message size of a UDP message to 65507 bytes. Therefore, using the maximum socket buffer size will allow multiple maximum-sized messages to be placed on the send queue. The default inbound and outbound message size limit for a UDP datagram socket is 65535 bytes. The maximum message size for a UDP broadcast is limited by the MTU size of the underlying link. ERRORS
One of the following errors may be returned in if a socket operation fails. For a more detailed list of errors, see the man pages for spe- cific system calls. [EISCONN] Attempt to send a datagram with the destination address specified, when the socket is already connected. [ENOBUFS] No buffer space is available for an internal data structure. [EADDRINUSE] Attempt to create a socket with a port which has already been allocated. [EADDRNOTAVAIL] Attempt to create a socket with a network address for which no network interface exists. AUTHOR
The socket interfaces to UDP were developed by the University of California, Berkeley. SEE ALSO
ndd(1M). getsockopt(2), recv(2), send(2), socket(2), t_open(3), t_optmgmt(3) inet(7F), socket(7), RFC 768 User Datagram Protocol RFC 1122 Requirements for Internet hosts UDP(7P)
Man Page