Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ttyldisc_lookup(9) [netbsd man page]

LINEDISC(9)						   BSD Kernel Developer's Manual					       LINEDISC(9)

NAME
linedisc, ttyldisc_add, ttyldisc_lookup, ttyldisc_remove -- extensible line discipline framework SYNOPSIS
#include <sys/conf.h> int ttyldisc_add(struct linesw *disc, int no); struct linesw * ttyldisc_remove(const char *name); struct linesw * ttyldisc_lookup(const char *name); DESCRIPTION
The NetBSD TTY line discipline framework allows extensibility. Modules that need special line disciplines can add them as convenient and do not need to modify tty_conf.c. Line disciplines are now managed by a string, rather than number. Once the framework has been initialized, a new line discipline can be added by creating and initializing a struct linesw and calling ttyldisc_add(). The following is a brief description of each function in the framework: ttyldisc_add() Register a line discipline. The l_name field of the struct linesw should point to a string which is to be the symbolic name of that line discipline. For compatibility purposes, a line discipline number can be passed in no, but for new dis- ciplines this should be set to -1. ttyldisc_lookup() Look up a line discipline by name. NULL is returned if it can not be found. ttyldisc_remove() Remove a line discipline called name and return a pointer to it. If the discipline cannot be found or removed ttyldisc_remove() will return NULL. SEE ALSO
tty(4) HISTORY
The linedisc functions were added in NetBSD 1.6. AUTHORS
The NetBSD extensible line discipline framework was created by Eduardo Horvath <eeh@NetBSD.org>. BSD
November 1, 2000 BSD

Check Out this Related Man Page

ALTQ(4) 						   BSD Kernel Interfaces Manual 						   ALTQ(4)

NAME
ALTQ -- alternate queuing of network packets SYNOPSIS
options ALTQ options ALTQ_CBQ options ALTQ_RED options ALTQ_RIO options ALTQ_HFSC options ALTQ_CDNR options ALTQ_PRIQ DESCRIPTION
The ALTQ framework provides several disciplines for queuing outgoing network packets. This is done by modifications to the interface packet queues. See altq(9) for details. The user interface for ALTQ is implemented by the pfctl(8) utility, so please refer to the pfctl(8) and the pf.conf(5) manpages for a com- plete description of the ALTQ capabilities and how to use it. Kernel Options The following options in the kernel configuration file are related to ALTQ operation: ALTQ Enable ALTQ. ALTQ_CBQ Build the ``Class Based Queuing'' discipline. ALTQ_RED Build the ``Random Early Detection'' extension. ALTQ_RIO Build ``Random Early Drop'' for input and output. ALTQ_HFSC Build the ``Hierarchical Packet Scheduler'' discipline. ALTQ_CDNR Build the traffic conditioner. This option is meaningless at the moment as the conditioner is not used by any of the available disciplines or consumers. ALTQ_PRIQ Build the ``Priority Queuing'' discipline. ALTQ_NOPCC Required if the TSC is unusable. ALTQ_DEBUG Enable additional debugging facilities. Note that ALTQ-disciplines cannot be loaded as kernel modules. In order to use a certain discipline you have to build it into a custom ker- nel. The pf(4) interface, that is required for the configuration process of ALTQ can be loaded as a module. SUPPORTED DEVICES
The driver modifications described in altq(9) are required to use a certain network card with ALTQ. They have been applied to the following hardware drivers: age(4), alc(4), ale(4), an(4), ath(4), aue(4), bce(4), bfe(4), bge(4), cas(4), dc(4), de(4), ed(4), em(4), ep(4), epair(4), fxp(4), gem(4), hme(4), ipw(4), iwi(4), jme(4), le(4), msk(4), mxge(4), my(4), nfe(4), nge(4), npe(4), nve(4), ral(4), re(4), rl(4), rum(4), sf(4), sge(4), sis(4), sk(4), ste(4), stge(4), txp(4), udav(4), ural(4), vge(4), vr(4), wi(4), and xl(4). The ndis(4) framework also has support for ALTQ and thus all encapsulated drivers. The tun(4) and ng_iface(4) pseudo drivers also do support ALTQ. SEE ALSO
pf(4), pf.conf(5), ipfw(8), pfctl(8), altq(9) BSD
April 14, 2010 BSD
Man Page