Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

skpc(9) [netbsd man page]

SKPC(9) 						   BSD Kernel Developer's Manual						   SKPC(9)

NAME
skpc -- skip a character in a byte string SYNOPSIS
#include <lib/libkern/libkern.h> int skpc(u_char mask, size_t size, u_char *cp); DESCRIPTION
The skpc() function scans the byte string cp, whose length is size, until it finds the first character which isn't equal to mask or the string is exhausted. RETURN VALUES
The skpc() function returns the number of characters skipped. HISTORY
The skpc() function emulates a VAX instruction with the same name. BSD
November 1, 2011 BSD

Check Out this Related Man Page

MEMMEM(3)						   BSD Library Functions Manual 						 MEMMEM(3)

NAME
memmem -- locate substring in byte string LIBRARY
Standard C Library (libc, -lc) SYNOPSIS
#include <string.h> void * memmem(const void *block, size_t blen, const void *pat, size_t plen); DESCRIPTION
The memmem() function locates the first occurrence of the binary string pat of size plen bytes in the byte string block of size blen bytes. RETURN VALUES
The memmem() function returns a pointer to the substring located, or NULL if no such substring exists within block. If plen is zero, block is returned, i.e. a zero length pat is deemed to match the start of the string, as with strstr(3). SEE ALSO
bm(3), memchr(3), strchr(3), strstr(3) STANDARDS
The memmem() function is not currently standardized. However, it is meant to be API compatible with functions in FreeBSD and Linux. HISTORY
memmem() first appeared in the Free Software Foundation's glibc library. BSD
March 12, 2005 BSD
Man Page