Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

memcmp(9) [netbsd man page]

MEMCMP(9)						   BSD Kernel Developer's Manual						 MEMCMP(9)

NAME
memcmp -- compare byte string SYNOPSIS
#include <sys/systm.h> int memcmp(const void *b1, const void *b2, size_t len); DESCRIPTION
The memcmp() function compares byte string b1 against byte string b2. Both strings are assumed to be len bytes long. RETURN VALUES
The memcmp() function returns zero if the two strings are identical, otherwise returns the difference between the first two differing bytes (treated as unsigned char values, so that '200' is greater than '', for example). Zero-length strings are always identical. STANDARDS
The memcmp() function conforms to ANSI X3.159-1989 (``ANSI C89''). BSD
July 7, 2001 BSD

Check Out this Related Man Page

MEMCMP(3)						   BSD Library Functions Manual 						 MEMCMP(3)

NAME
memcmp -- compare byte string LIBRARY
Standard C Library (libc, -lc) SYNOPSIS
#include <string.h> int memcmp(const void *s1, const void *s2, size_t n); DESCRIPTION
The memcmp() function compares byte string s1 against byte string s2. Both strings are assumed to be n bytes long. RETURN VALUES
The memcmp() function returns zero if the two strings are identical, otherwise returns the difference between the first two differing bytes (treated as unsigned char values, so that '200' is greater than '', for example). Zero-length strings are always identical. This behav- ior is not required by C and portable code should only depend on the sign of the returned value. SEE ALSO
bcmp(3), strcasecmp(3), strcmp(3), strcoll(3), strxfrm(3), wmemcmp(3) STANDARDS
The memcmp() function conforms to ISO/IEC 9899:1990 (``ISO C90''). BSD
June 4, 1993 BSD
Man Page