Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

linedisc(9) [netbsd man page]

LINEDISC(9)						   BSD Kernel Developer's Manual					       LINEDISC(9)

NAME
linedisc, ttyldisc_add, ttyldisc_lookup, ttyldisc_remove -- extensible line discipline framework SYNOPSIS
#include <sys/conf.h> int ttyldisc_add(struct linesw *disc, int no); struct linesw * ttyldisc_remove(const char *name); struct linesw * ttyldisc_lookup(const char *name); DESCRIPTION
The NetBSD TTY line discipline framework allows extensibility. Modules that need special line disciplines can add them as convenient and do not need to modify tty_conf.c. Line disciplines are now managed by a string, rather than number. Once the framework has been initialized, a new line discipline can be added by creating and initializing a struct linesw and calling ttyldisc_add(). The following is a brief description of each function in the framework: ttyldisc_add() Register a line discipline. The l_name field of the struct linesw should point to a string which is to be the symbolic name of that line discipline. For compatibility purposes, a line discipline number can be passed in no, but for new dis- ciplines this should be set to -1. ttyldisc_lookup() Look up a line discipline by name. NULL is returned if it can not be found. ttyldisc_remove() Remove a line discipline called name and return a pointer to it. If the discipline cannot be found or removed ttyldisc_remove() will return NULL. SEE ALSO
tty(4) HISTORY
The linedisc functions were added in NetBSD 1.6. AUTHORS
The NetBSD extensible line discipline framework was created by Eduardo Horvath <eeh@NetBSD.org>. BSD
November 1, 2000 BSD

Check Out this Related Man Page

TB(4)							     Kernel Interfaces Manual							     TB(4)

NAME
tb - line discipline for digitizing devices SYNOPSIS
/sys/conf/SYSTEM: NTB 1 # RS232 interface for Genisco/Hitachi tablets DESCRIPTION
This line discipline provides a polled interface to many common digitizing devices which are connected to a host through a serial line. When these devices stream data at high speed, the use of the line discipline is critical in minimizing the number of samples that would otherwise be lost due to buffer exhaustion in the tty(4) handler. The line discipline is enabled by a sequence: #include <sys/tablet.h> int ldisc = TBLDISC, fildes; ... ioctl(fildes, TIOCSETD, &ldisc); A typical application program then polls the digitizing device by reading a binary data structure which contains: the current X and Y posi- tions (in the device coordinate space), up-down status of the buttons or pen stylus, proximity information (when available), and a count of the number of samples received from the input device since it was opened. In addition, devices such as the GTCO append tilt and pressure information to the end of the aforementioned structure. For the Polhemus 3-D digitizer the structure read is completely different. Refer to the include file for a complete description. While in tablet mode, normal teletype input and output functions take place. Thus, if an 8 bit output data path is desired, it is neces- sary to prepare the output line by putting it into RAW mode using ioctl(2). This must be done before changing the discipline with TIOC- SETD, as most ioctl(2) calls are disabled while in tablet line-discipline mode. The line discipline supports ioctl(2) requests to get/set the operating mode, and to get/set the tablet type and operating mode by or-ing the two values together. The line discipline supports digitizing devices which are compatible with Hitachi, GTCO, or Polhemus protocol formats. For Hitachi there are several formats with that used in the newer model HDG-1111B the most common. SEE ALSO
tty(4) DIAGNOSTICS
None. 3rd Berkeley Distribution August 1, 1987 TB(4)
Man Page