Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

enodev(9) [netbsd man page]

NULLOP(9)						   BSD Kernel Developer's Manual						 NULLOP(9)

NAME
nullop -- dummy functions SYNOPSIS
#include <sys/systm.h> int nullop(void *v); void voidop(void); int enodev(void); int enxio(void); int enoioctl(void); int enosys(void); int eopnotsupp(void); DESCRIPTION
The nullop() function provides a generic ``null operation''. It always returns the value 0. The voidop() function takes no arguments and does nothing. The enodev(), enxio(), enoioctl(), enosys(), and eopnotsupp() functions always fail, returning ENODEV, ENXIO, ENOTTY, ENOSYS, and EOPNOTSUPP, respectively. EXAMPLES
The following example demonstrates a case where nullop() may be useful: uint64_t xc; ... xc = xc_broadcast(0, (xcfunc_t)nullop, NULL, NULL); xc_wait(xc); BSD
July 25, 2010 BSD
Man Page

8 More Discussions You Might Find Interesting

1. Solaris

Core dump failures

Does anyone have a list of error codes when core dumps fail? What is error 4? I also have another box that does error-2 occasionally. if anyone has a list of these error codes, it would be appreciated, thanks! I have the error below: NOTICE: core_log: ns-admin core dump failed,... (2 Replies)
Discussion started by: BG_JrAdmin
2 Replies

2. Solaris

/var/cron/log Return Codes

I want to know if there is any documentation or any type of information that can give a list of all of the return codes that can be seen in the /var/cron/log. I have seen a couple in my log file. Example: rc=1 and rc=64. (2 Replies)
Discussion started by: sjames
2 Replies

3. AIX

Problem with login on AIX 5306

Hello Guys, I am working on AIX 5306,when I ssh on to the server it just hangs.but I can still run commands remotely through ssh without logging in to the server. I am not able to find out the problem,it's not only ssh even the telnet or normal login does not want to work it just hangs.when I... (6 Replies)
Discussion started by: noori
6 Replies

4. SCO

Any device driver sample for SCO ?!

Hi I'm looking for a simple and nice sample for writing a device driver in SCO OpenServer 5.0.7. I'm asked to write a device driver for some usb printer. I have already the linux version of the driver but it won't get compiled. I have some basic knowledge of device drivers phenomena such as kernel... (4 Replies)
Discussion started by: k.a.docpp
4 Replies

5. UNIX for Dummies Questions & Answers

Read Bash Script

I am very new to all these programming languages and really love Linux but have only begun to dive into bash scripting... I am curious what's going on with this script... #!/bin/bash if ; then # xen grep control_d /proc/xen/capabilities >& /dev/null if ; then # domU -- do not run on... (2 Replies)
Discussion started by: BrianBlaze
2 Replies

6. Ubuntu

Kernel panics : trying to write / read on tiny tty driver

I'm a beginner to the Linux programming and trying my hands on some device driver examples while practising. The below code (a trimmed down version of tiny_tty.c from ldd3 book) loads perfectly using insmod and I'm able to see it in /proc/tty/drivers , /proc/modules and device nodes are getting... (1 Reply)
Discussion started by: diwsdiwa
1 Replies

7. UNIX for Advanced & Expert Users

Kernel crash - NULL pointer dereference when calling DEVICE_WRITE from KTHREAD in a USB device drive

I'm writing a simple USB driver to drive a stepper motor based on USB Skeleton 2.2 Driver, kernel 3.8. The basic version is running properly. As a advancement, I introduced KTHREAD to call the DEVICE_WRITE (skel_write) (), so that the driver will be available for other tasks & requests. Calling... (0 Replies)
Discussion started by: miteshgaware
0 Replies

8. Red Hat

Cause PCIe error callbacks using AER injection

I am trying to cause a callback in the Linux nvme driver by using AER injection. I've modified the AER source code to directly inject errors through module loading rather than from userland program. I've verified that I got the correct bus, dev, and fn and that the error injection went... (0 Replies)
Discussion started by: Decrypto
0 Replies