Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

curproc(9) [netbsd man page]

CURPROC(9)						   BSD Kernel Developer's Manual						CURPROC(9)

NAME
curproc, curcpu, curlwp -- current process, processor, and LWP SYNOPSIS
#include <sys/proc.h> struct cpu_info * curcpu(void); struct proc * curproc(void); struct lwp * curlwp(void); DESCRIPTION
The following macros can be used to retrieve the current processor, process, and light-weight process (LWP), respectively: 1. The machine-dependent curcpu() macro returns a pointer to a cpu_info structure containing information of the CPU that this thread is running on. 2. The machine-independent curproc() macro refers to a pointer to the process currently running on this CPU. 3. The curlwp() macro expands to a pointer to lwp structure, containing information about the current LWP. This macro is machine- independent, but machine-dependent <machine/cpu.h> may redefine it. SEE ALSO
cpu_number(9), proc_find(9) BSD
July 1, 2010 BSD

Check Out this Related Man Page

_LWP_UNPARK(2)						      BSD System Calls Manual						    _LWP_UNPARK(2)

NAME
_lwp_unpark -- resume execution of a waiting LWP LIBRARY
Standard C Library (libc, -lc) SYNOPSIS
#include <lwp.h> int _lwp_unpark(lwpid_t lwp, const void *hint); DESCRIPTION
_lwp_unpark() resumes execution of the light-weight process lwp. The target LWP is assumed to be waiting in the kernel as a result of a call to _lwp_park(). If the target LWP is not currently waiting, it will return immediately upon the next call to _lwp_park(). See _lwp_park(2) for a description of the hint argument. RETURN VALUES
A 0 value indicates that the call succeeded. A -1 return value indicates an error occurred and errno is set to indicate the reason. ERRORS
[ESRCH] No LWP can be found in the current process corresponding to that specified by lwp. SEE ALSO
_lwp_park(2), _lwp_unpark_all(2), _lwp_wakeup(2) HISTORY
The _lwp_unpark() system call first appeared in NetBSD 5.0. BSD
January 20, 2007 BSD
Man Page