Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

cpu_configure(9) [netbsd man page]

CPU_CONFIGURE(9)					   BSD Kernel Developer's Manual					  CPU_CONFIGURE(9)

NAME
cpu_configure -- machine-dependent device autoconfiguration SYNOPSIS
#include <sys/systm.h> void cpu_configure(void); DESCRIPTION
The machine-dependent cpu_configure() is called during system bootstrap to perform the machine-dependent portion of device autoconfiguration. It sets the configuration machinery in motion by finding the root bus (``mainbus''). When this function returns, interrupts must be enabled. The following tasks are performed by cpu_configure(): o initialize soft interrupts (see softintr(9)); o initialize CPU interrupts and SPLs (see spl(9)); o call config_rootfound() for ``mainbus''; and o complete any initialization deferred from cpu_startup(9). SEE ALSO
autoconf(9), cpu_startup(9) BSD
April 13, 2010 BSD

Check Out this Related Man Page

spl(9r) 																   spl(9r)

NAME
spl - General: Sets the processor priority to mask different levels of interrupts SYNOPSIS
#include <machine/cpu.h> int getspl( void ); int splbio( void ); int splclock( void ); int spldevhigh( void ); int splextreme( void ); int splhigh( void ); int splimp( void ); int splnet( void ); int splnone( void ); int splsched( void ); int splsoftclock( void ); int spltty( void ); int splvm( void ); int splx( int x ); ARGUMENTS
Specifies a CPU priority level. This level must be a value returned by a previous call to one of the spl routines. DESCRIPTION
The operating system supports the naming of spl routines to indicate the associated device types. Named spl routines make it easier to determine which routine you should use to set the priority level for a given device type. The following table summarizes the uses for the different spl routines: Obtains the spl value. Masks all disk and tape controller interrupts. Masks all hardware clock interrupts. Masks all device and software interrupts. Blocks against all but halt interrupts. Masks all interrupts except for realtime devices, machine checks, and halt interrupts. Masks all LAN hardware interrupts. Masks all network software interrupts. Unmasks (enables) all interrupts. Masks all scheduling interrupts (usually the hardware clock). Masks all software clock interrupts. Masks all tty (terminal device) inter- rupts. Masks all virtual memory clock interrupts. Resets the CPU priority to the level specified by the argument. NOTES
The binding of any spl routine with a specific CPU priority level is highly machine dependent. With the exceptions of the splhigh and splnone routines, knowledge of the explicit bindings is not required to create new device drivers. You always use splhigh to mask (disable) all interrupts and splnone to unmask (enable) all interrupts. RETURN VALUES
Upon successful completion, each spl routine returns an integer value that represents the CPU priority level that existed before it was changed by a call to the specified spl routine. EXAMPLE
The following code fragment shows the use of spl routines as part of a disk strategy routine: int s; . . . s = splbio(); /* Mask (disable) all disk interrupts */ . . . [Code to deal with data that can be modified by the disk interrupt code] . . . splx(s); /* Restore CPU priority to what it was */ spl(9r)
Man Page

13 More Discussions You Might Find Interesting

1. Tips and Tutorials

Unix File Permissions

Introduction I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls: $ ls -ld /usr/bin /usr/bin/cat drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin -r-xr-xr-x 1 bin bin ... (6 Replies)
Discussion started by: Perderabo
6 Replies

2. Shell Programming and Scripting

sorting left-justified numeric values

I have a file which looks roughly like this: 996 mmmmmmm 996 xxxxxxxxxxxxx 99600 ssssssssss 9964 fffffffffffff and would like to sort it numerically on the first field. I tried: sort -nr --key=1 .... The output I get is: 99600 ssssssssss 9964 ... (3 Replies)
Discussion started by: rovf
3 Replies

3. Programming

Memory Leaks

Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram. main() { malloc(1gb) return(0) } The program above exits without freeing the memory. In this case will the 1 gb of heap memory be returned... (9 Replies)
Discussion started by: rupeshkp728
9 Replies

4. Solaris

How to install PGX32 on Sparc 10 Ultra?

I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10. I've got the Oracle installation guide for it and I got as far as: "4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive." I don't have a CD-ROM by that name and a web search for that... (21 Replies)
Discussion started by: Michele31416
21 Replies

5. Shell Programming and Scripting

Better to Use Return Code or wc -l Output?

Hey All, Quick question... I'm writing a short script to check if a continuous port is running on a server. I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the return code from the command or if its better to pipe to... (12 Replies)
Discussion started by: mrm5102
12 Replies

6. Shell Programming and Scripting

Vm versus physical linux server

Does anyone have a script that can be run to tell you if you are on either a VM Linux or a physical Linux server? (15 Replies)
Discussion started by: bigbenn
15 Replies

7. BSD

NetBSD 6.1.2: apm and admd not found

I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system? Is it necessary to recompile the default amd64 kernel to use apm? Or is there a new method for power management and suspend/resume? (2 Replies)
Discussion started by: bsdx
2 Replies

8. Shell Programming and Scripting

RFC - Korn shell prompt

Hi, I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD. So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post. The prompt is... (2 Replies)
Discussion started by: gezley
2 Replies

9. Shell Programming and Scripting

Make bold chars in UNIX

Hi all, I want to make the string as bold in unix. is there any way to acheive this? thanks in advance. (16 Replies)
Discussion started by: SekhaReddy
16 Replies

10. Shell Programming and Scripting

Adding a List of Times

Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Discussion started by: Brusimm
5 Replies

11. UNIX for Beginners Questions & Answers

BSD Unix Toolbox: 1000+ Commands for FreeBSD, OpenBSD, and NetBSD

Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;) But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
Discussion started by: fossiili
0 Replies

12. UNIX for Beginners Questions & Answers

Grandpa returning to UNIX

On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)
Discussion started by: fossiili
13 Replies

13. UNIX for Beginners Questions & Answers

Grep command to show the number of results

Hi I wanted to know if there is an option in grep command to show the number of results (not the number of lines of findings). Thanks (14 Replies)
Discussion started by: abdossamad2003
14 Replies