Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

iasl(8) [netbsd man page]

IASL(8) 						    BSD System Manager's Manual 						   IASL(8)

NAME
iasl -- Intel ASL compiler and disassembler (iASL) SYNOPSIS
iasl [options] <input file> DESCRIPTION
The iasl is a fully-featured compiler for the ACPI Source Language (ASL). It translates ASL to ACPI Machine Language (AML), but iasl can also act as a disassembler, translating AML to ASL. OPTIONS
Global -@ file Specify command file. -I dir Specify additional include directory. General Output -p prefix Specify a path or filename prefix for all output files. -va Disable all errors and warnings in the summary. -vi Use less verbose errors and warnings. -vo Enable optimization comments. -vr Disable remarks. -vs Disable signon. -w 1 | 2 | 3 Set warning reporting level. AML Output Files -s a | c Create AML in assembler (*.asm) or C (*.c) source file. -i a | c Create assembler (*.inc) or C (*.h) include file. -t a | c Create AML in assembler or C hex table (*.hex). AML Code Generation -oa Disable all optimizations (compatibility mode). -of Disable constant folding. -oi Disable integer optimization to operation codes. -on Disable named reference string optimization. -r revision Override table header revision (1-255). Listings -l Create mixed, ASL and AML, listing file (*.lst). -ln Create namespace file (*.nsp). -ls Create combined source file (*.src). AML Disassembler -d file Disassemble binary ACPI table to a file (*.dsl). -dc file Disassemble AML and immediately compile it. -e f1, f2 Include ACPI table(s) for external symbol resolution. -2 Emit ACPI 2.0 compatible ASL code. -g Get ACPI tables and write to files (*.dat). Help -h Display additional help and compiler debug options. -hc Display operators allowed in constant expressions. -hr Display ACPI reserved method names. SEE ALSO
acpi(4), acpidump(8), amldb(8) Intel Corporation, iASL Compiler/Disassembler User Reference, Revision 2.00, http://www.acpica.org/download/aslcompiler.pdf, September 18, 2009. HISTORY
The iasl compiler/disassembler is part of the Intel ACPI Component Architecture (ACPICA). It first appeared in NetBSD 6.0. AUTHORS
Among Intel engineers, Robert Moore <robert.moore@intel.com> was the chief architect behind iasl. This manual page was written for NetBSD by Jukka Ruohonen <jruohonen@iki.fi>. BSD
April 10, 2010 BSD

Check Out this Related Man Page

IASL(8) 						    BSD System Manager's Manual 						   IASL(8)

NAME
iasl -- Intel ACPI compiler/decompiler SYNOPSIS
iasl [-2cefghl] [-b type] [-d file] [-dc file] [-hc] [-hr] [-i type] [-ln] [-ls] [-oa] [-of] [-oi] [-on] [-ot] [-p prefix] [-s type] [-t type] [-vi] [-vo] [-vr] [-vs] [-x level] [-w level] input-file DESCRIPTION
The iasl utility is a compiler/decompiler for ACPI Source Language (ASL) and ACPI Machine Language (AML). Major features of iasl include: o Full support for the ACPI 3.0b Specification including ASL grammar elements and operators. o Extensive compiler syntax and semantic error checking, especially in the area of control methods. This reduces the number of errors that are not discovered until the AML code is actually interpreted (i.e., the compile-time error checking reduces the number of run-time errors). o Multiple types of output files, including formatted listing files with intermixed source, several types of AML files, and error messages. OPTIONS
-2 Emit ACPI 2.0 compatible ASL code. -b p|t|b Create compiler debug/trace file (*.txt). Types: Parse/Tree/Both. -c Parse only, no output generation. -d file Disassemble AML to ASL source code file (*.dsl). -dc file Disassemble AML and immediately compile it. (Obtain DSDT from current system if no input file.) -e Generate External() statements for unresolved symbols. -f Ignore errors, force creation of AML output file(s). -g Get ACPI tables and write to files (*.dat). -h Additional help and compiler debug options. -hc Display operators allowed in constant expressions. -hr Display ACPI reserved method names. -i a|c Create assembler or C include file (*.inc or *.h). -l Create mixed listing file (ASL source and AML) (*.lst). -ln Create namespace file (*.nsp). -ls Create combined source file (expanded includes) (*.src). -oa Disable all optimizations (compatibility mode). -of Disable constant folding. -oi Disable integer optimization to Zero/One/Ones. -on Disable named reference string optimization. -ot Display compile times. -p prefix Specify filename prefix for all output files (including .aml). -s a|c Create AML in assembler or C source file (*.asm or *.c). -t a|c Create AML in assembler or C hex table (*.hex). -vi Less verbose errors and warnings for use with IDEs. -vo Enable optimization comments. -vr Disable remarks. -vs Disable signon. -x level Set debug level for trace output. -w level Set warning level. SEE ALSO
acpi(4), acpidump(8) HISTORY
The iasl utility is provided with Intel ACPI-CA. It first appeared in FreeBSD 5.2. AUTHORS
The iasl utility was written by Intel. This manual page was written by Nate Lawson. BSD
May 20, 2008 BSD
Man Page