Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

iic(4) [netbsd man page]

IIC(4)							   BSD Kernel Interfaces Manual 						    IIC(4)

NAME
iic -- Inter IC (I2C) bus SYNOPSIS
iic* at alipm? # sparc64 iic* at acpismbus? # amd64 i386 iic* at amdpm? # amd64 i386 iic* at armadillo9iic? # evbarm iic0 at at91twi? # evbarm iic0 at ausmbus0 # evbmips iic0 at cuda0 # macppc iic0 at gpiic? # evbppc iic* at gpioiic? # amd64 i386 iic* at gtiic? # evbppc iic* at gxiic? # evbarm iic* at ichsmb? # amd64 i386 iic0 at iociic0 # acorn26 iic0 at iomdiic? # acorn32 iic0 at iopiic? # evbarm iyonix iic* at ki2c? # macppc iic* at nfsmb? # amd64 i386 iic* at ociic? # sandpoint iic* at piixpm? # amd64 i386 iic0 at slugiic0 # evbarm iic* at viapcib? # i386 DESCRIPTION
I2C is a two-wire bus developed by Philips used for connecting integrated circuits. It is commonly used for connecting devices such as EEP- ROMs, temperature sensors, fan controllers, real-time clocks, tuners, and other types of integrated circuits. The iic driver provides a uniform programming interface layer between I2C master controllers and various I2C slave devices. Each I2C master controller attaches an iic framework; several slave devices can then be attached to the iic bus. All I2C slave devices are uniquely identified by the address on the bus. The master accesses a particular slave device using its address. System Management Bus (SMBus) protocol is also supported by emulating it with the I2C commands. SUPPORTED MASTERS
A wide list of I2C masters are supported, among them are: alipm(4) Acer Labs M7101 SMBus controller acpismbus(4) ACPI SMBus Control Method Interface amdpm(4) AMD768 Power Management Controller and AMD8111 System Management Controller armadillo9iic(4) at91twi(4) ausmbus(4) cuda(4) support for CUDA microcontrollers found in many Power Macintosh and and compatible computers gpiic(4) gtiic(4) gxiic(4) ichsmb(4) Intel ICH SMBus controller iociic(4) iomdiic(4) iopiic(4) ki2c(4) gpioiic(4) GPIO bit-banging nfsmb(4) NVIDIA nForce 2/3/4 SMBus controller and SMBus driver ociic(4) piixpm(4) Intel PIIX and compatible Power Management controller slugiic(4) viapcib(4) SUPPORTED SLAVES
A wide list of slaves are supported, among them: dbcool(4) dbCool(tm) family of environmental monitors and fan controllers rs5c372rtc(4) RICOH RS5C372A and RS5C372B real-time clock sgsmix(4) driver for SGS 7433 Basic Audio Processor found in some Apple machines spdmem(4) Generic Memory Module Serial Presence Detect SEE ALSO
dtviic(4), intro(4), i2cscan(8), iic(9) HISTORY
The I2C framework first appeared in NetBSD 2.0. OpenBSD support was added in OpenBSD 3.6. This manpage first appeared in NetBSD 6.0, it was ported from OpenBSD. AUTHORS
The I2C framework was written by Steve C. Woodford and Jason R. Thorpe for NetBSD and then ported to OpenBSD by Alexander Yurchenko <grange@openbsd.org>. BSD
October 15, 2011 BSD

Check Out this Related Man Page

IIC(4)							   BSD Kernel Interfaces Manual 						    IIC(4)

NAME
iic -- I2C generic I/O device driver SYNOPSIS
device iic #include <dev/iicbus/iic.h> DESCRIPTION
The iic device driver provides generic I/O to any iicbus(4) instance. In order to control I2C devices, use /dev/iic? with the following ioctls: I2CSTART (struct iiccmd) Sends the start condition to the slave specified by the slave element to the bus. All other elements are ignored. I2CRPTSTART (struct iiccmd) Sends the repeated start condition to the slave specified by the slave element to the bus. All other elements are ignored. I2CSTOP No argument is passed. Sends the stop condition to the bus. This terminates the current transaction. I2CRSTCARD (struct iiccmd) Resets the bus. The argument is completely ignored. I2CWRITE (struct iiccmd) Writes data to the iicbus(4). The bus should already be started. The slave element is ignored. The count ele- ment is the number of bytes to write. The last element is a boolean flag. It is non-zero when additional write commands will follow. The buf element is a pointer to the data to write to the bus. I2CREAD (struct iiccmd) Reads data from the iicbus(4). The bus should already be started. The slave element is ignored. The count element is the number of bytes to write. The last element is a boolean flag. It is non-zero when additional write commands will follow. The buf element is a pointer to where to store the data read from the bus. Short reads on the bus produce unde- fined results. I2CRDWR (struct iic_rdwr_data) Generic read/write interface. Allows for an arbitrary number of commands to be sent to an arbitrary num- ber of devices on the bus. A read transfer is specified if IIC_M_RD is set in flags. Otherwise the transfer is a write trans- fer. The slave element specifies the 7-bit address for the transfer. The len element is the length of the data. The buf ele- ment is a buffer for that data. This ioctl is intended to be Linux compatible. The following data structures are defined in <dev/iicbus/iic.h> and referenced above: struct iiccmd { u_char slave; int count; int last; char *buf; }; /* Designed to be compatible with linux's struct i2c_msg */ struct iic_msg { uint16_t slave; uint16_t flags; #define IIC_M_RD 0x0001 /* read vs write */ uint16_t len; /* msg legnth */ uint8_t * buf; }; struct iic_rdwr_data { struct iic_msg *msgs; uint32_t nmsgs; }; It is also possible to use read/write routines, then I2C start/stop handshake is managed by the iicbus(4) system. However, the address used for the read/write routines is the one passed to last I2CSTART ioctl(2) to this device. SEE ALSO
ioctl(2), read(2), write(2), iicbus(4) HISTORY
The iic manual page first appeared in FreeBSD 3.0. AUTHORS
This manual page was written by Nicolas Souchu and M. Warner Losh. BUGS
Only the I2CRDWR ioctl(2) is thread safe. All other interfaces suffer from some kind of race. BSD
September 6, 2006 BSD
Man Page