Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

iic(4) [netbsd man page]

IIC(4)							   BSD Kernel Interfaces Manual 						    IIC(4)

NAME
iic -- Inter IC (I2C) bus SYNOPSIS
iic* at alipm? # sparc64 iic* at acpismbus? # amd64 i386 iic* at amdpm? # amd64 i386 iic* at armadillo9iic? # evbarm iic0 at at91twi? # evbarm iic0 at ausmbus0 # evbmips iic0 at cuda0 # macppc iic0 at gpiic? # evbppc iic* at gpioiic? # amd64 i386 iic* at gtiic? # evbppc iic* at gxiic? # evbarm iic* at ichsmb? # amd64 i386 iic0 at iociic0 # acorn26 iic0 at iomdiic? # acorn32 iic0 at iopiic? # evbarm iyonix iic* at ki2c? # macppc iic* at nfsmb? # amd64 i386 iic* at ociic? # sandpoint iic* at piixpm? # amd64 i386 iic0 at slugiic0 # evbarm iic* at viapcib? # i386 DESCRIPTION
I2C is a two-wire bus developed by Philips used for connecting integrated circuits. It is commonly used for connecting devices such as EEP- ROMs, temperature sensors, fan controllers, real-time clocks, tuners, and other types of integrated circuits. The iic driver provides a uniform programming interface layer between I2C master controllers and various I2C slave devices. Each I2C master controller attaches an iic framework; several slave devices can then be attached to the iic bus. All I2C slave devices are uniquely identified by the address on the bus. The master accesses a particular slave device using its address. System Management Bus (SMBus) protocol is also supported by emulating it with the I2C commands. SUPPORTED MASTERS
A wide list of I2C masters are supported, among them are: alipm(4) Acer Labs M7101 SMBus controller acpismbus(4) ACPI SMBus Control Method Interface amdpm(4) AMD768 Power Management Controller and AMD8111 System Management Controller armadillo9iic(4) at91twi(4) ausmbus(4) cuda(4) support for CUDA microcontrollers found in many Power Macintosh and and compatible computers gpiic(4) gtiic(4) gxiic(4) ichsmb(4) Intel ICH SMBus controller iociic(4) iomdiic(4) iopiic(4) ki2c(4) gpioiic(4) GPIO bit-banging nfsmb(4) NVIDIA nForce 2/3/4 SMBus controller and SMBus driver ociic(4) piixpm(4) Intel PIIX and compatible Power Management controller slugiic(4) viapcib(4) SUPPORTED SLAVES
A wide list of slaves are supported, among them: dbcool(4) dbCool(tm) family of environmental monitors and fan controllers rs5c372rtc(4) RICOH RS5C372A and RS5C372B real-time clock sgsmix(4) driver for SGS 7433 Basic Audio Processor found in some Apple machines spdmem(4) Generic Memory Module Serial Presence Detect SEE ALSO
dtviic(4), intro(4), i2cscan(8), iic(9) HISTORY
The I2C framework first appeared in NetBSD 2.0. OpenBSD support was added in OpenBSD 3.6. This manpage first appeared in NetBSD 6.0, it was ported from OpenBSD. AUTHORS
The I2C framework was written by Steve C. Woodford and Jason R. Thorpe for NetBSD and then ported to OpenBSD by Alexander Yurchenko <grange@openbsd.org>. BSD
October 15, 2011 BSD

Check Out this Related Man Page

I2C(8)							    BSD System Manager's Manual 						    I2C(8)

NAME
i2c -- test I2C bus and slave devices SYNOPSIS
i2c -a address [-f device] [-d r|w] [-w 0|8|16] [-o offset] [-c count] [-m ss|rs|no] [-b] [-v] i2c -s [-f device] [-n skip_addr] [-v] i2c -r [-f device] [-v] DESCRIPTION
The i2c utility can be used to perform raw data transfers (read or write) with devices on the I2C bus. It can also scan the bus for available devices and reset the I2C controller. The options are as follows: -a address 7-bit address on the I2C device to operate on (hex). -b binary mode - when performing a read operation, the data read from the device is output in binary format on stdout; when doing a write, the binary data to be written to the device is read from stdin. -c count number of bytes to transfer (dec). -d r|w transfer direction: r - read, w - write. -f device I2C bus to use (default is /dev/iic0). -m ss|rs|no addressing mode, i.e., I2C bus operations performed after the offset for the transfer has been written to the device and before the actual read/write operation. rs - repeated start; ss - stop start; no - none. -n skip_addr skip address - address(es) to be skipped during bus scan. There are two ways to specify addresses to ignore: by range 'a..b' or using selected addresses 'a:b:c'. This option is available only when "-s" is used. -o offset offset within the device for data transfer (hex). -r reset the controller. -s scan the bus for devices. -v be verbose. -w 0|8|16 device addressing width (in bits). WARNINGS
Great care must be taken when manipulating slave I2C devices with the i2c utility. Often times important configuration data for the system is kept in non-volatile but write enabled memories located on the I2C bus, for example Ethernet hardware addresses, RAM module parameters (SPD), processor reset configuration word etc. It is very easy to render the whole system unusable when such configuration data is deleted or altered, so use the ``-d w'' (write) command only if you know exactly what you are doing. Also avoid ungraceful interrupting of an ongoing transaction on the I2C bus, as it can lead to potentially dangerous effects. Consider the following scenario: when the host CPU is reset (for whatever reason) in the middle of a started I2C transaction, the I2C slave device could be left in write mode waiting for data or offset to arrive. When the CPU reinitializes itself and talks to this I2C slave device again, the commands and other control info it sends are treated by the slave device as data or offset it was waiting for, and there's great potential for corruption if such a write is performed. EXAMPLES
o Scan the default bus (/dev/iic0) for devices: i2c -s o Scan the default bus (/dev/iic0) for devices and skip addresses 0x56 and 0x45. i2c -s -n 0x56:0x45 o Scan the default bus (/dev/iic0) for devices and skip address range 0x34 to 0x56. i2c -s -n 0x34..0x56 o Read 8 bytes of data from device at address 0x56 (e.g., an EEPROM): i2c -a 0x56 -d r -c 8 o Write 16 bytes of data from file data.bin to device 0x56 at offset 0x10: i2c -a 0x56 -d w -c 16 -o 0x10 -b < data.bin o Copy 4 bytes between two EEPROMs (0x56 on /dev/iic1 to 0x57 on /dev/iic0): i2c -a 0x56 -f /dev/iic1 -d r -c 0x4 -b | i2c -a 0x57 -f /dev/iic0 -d w -c 4 -b o Reset the controller: i2c -f /dev/iic1 -r SEE ALSO
iic(4), iicbus(4) HISTORY
The i2c utility appeared in FreeBSD 8.0. AUTHORS
The i2c utility and this manual page were written by Bartlomiej Sieka <tur@semihalf.com> and Michal Hajduk <mih@semihalf.com>. BSD
January 23, 2009 BSD
Man Page