Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

flash(4) [netbsd man page]

FLASH(4)						   BSD Kernel Interfaces Manual 						  FLASH(4)

NAME
flash -- device-independent flash layer SYNOPSIS
#include <sys/flash.h> DESCRIPTION
The flash driver provides a device-independent interface for using flash memory. The following ioctl(2) operations are supported on /dev/flash: FLASH_BLOCK_ISBAD (struct flash_badblock_params) This command checks if a block is marked as bad. FLASH_BLOCK_MARKBAD (struct flash_badblock_params) This command marks a block as bad. FLASH_DUMP (struct flash_dump_params) This command dumps a block. FLASH_ERASE_BLOCK (struct flash_erase_params) This command erases one or more blocks. FLASH_GET_INFO (struct flash_info_params) This command aquires information aboout the flash device. FILES
/dev/flash SEE ALSO
flash(9), nand(9) AUTHORS
Adam Hoka <ahoka@NetBSD.org> BSD
January 21, 2010 BSD

Check Out this Related Man Page

FLASH(9)						   BSD Kernel Developer's Manual						  FLASH(9)

NAME
flash -- subsystem for flash-like memory devices SYNOPSIS
#include <dev/flash/flash.h> device_t flash_attach_mi(const struct flash_interface *fl, device_t dev); DESCRIPTION
Flash-like devices can register themselves to the flash layer with the flash_hw_if structure. This structure has function pointers and other fields. The attachment can be done by calling flash_attach_mi() with this structure and the device's device_t as an argument. Return value is the flash layer device. The flash_interface structure is shown below. struct flash_interface { int (*erase) (device_t, struct flash_erase_instruction *); int (*read) (device_t, off_t, size_t, size_t *, uint8_t *); int (*write) (device_t, off_t, size_t, size_t *, const uint8_t *); int (*block_markbad)(device_t, uint64_t); int (*block_isbad)(device_t, uint64_t); int (*sync) (device_t); int (*submit)(device_t, struct buf *); /* storage for partition info */ struct flash_partition partition; /* total size of mtd */ flash_addr_t size; uint32_t page_size; uint32_t erasesize; uint32_t writesize; uint32_t minor; uint8_t type; }; SEE ALSO
flash(4), nand(9) AUTHORS
Adam Hoka <ahoka@NetBSD.org> BSD
March 31, 2011 BSD
Man Page

12 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Our First Flash Intro ?

(13 Replies)
Discussion started by: Neo
13 Replies

2. Post Here to Contact Site Administrators and Moderators

Our First Flash Intro ?

Well, someone created a flash intro for us (their first attempt at SWiSH!) OK, SECOND DRAFT: https://www.unix.com/test_intro2.swf --------------------------- FIRST DRAFT: https://www.unix.com/test_intro1.swf Notice it says "Search before posting a question"..... Well????... (24 Replies)
Discussion started by: Neo
24 Replies

3. Post Here to Contact Site Administrators and Moderators

Latest Design of New Unix Header (Flash)

As everyone might know by now, we have a new 'draft' banner with matrix theme, falling unix commands, blinking numbers, and more. This will be the new default theme for the forums. We are in the process of sending final comments to our designer, please feel free to post your suggestions here.... (20 Replies)
Discussion started by: Neo
20 Replies

4. Post Here to Contact Site Administrators and Moderators

How Many "Falling Unix Commands" are in the Flash Header?

A poll!! (10 Replies)
Discussion started by: Neo
10 Replies

5. SuSE

Problem with flash player

Hi All Im using Redhat Linux enterprise editon 4.0 When ever i open firefox, i get a msg saying that "Install missing plugins" When i click that macromedi flash player is downloaded. And after i install flash player also, in fireforx i get the same message Pls help me (11 Replies)
Discussion started by: balumankala
11 Replies

6. Linux

Problem with flash player

(11 Replies)
Discussion started by: balumankala
11 Replies

7. Solaris

removable usb flash drive

# rmformat Looking for devices... 1. Logical Node: /dev/rdsk/c0t0d0p0 Physical Node: /pci@0,0/pci-ide@1f,1/ide@0/sd@0,0 Connected Device: HL-DT-ST DVD+-RW GWA4164B E113 Device Type: DVD Reader/Writer 2. Logical Node: /dev/rdsk/c2t0d0p0 Physical Node:... (26 Replies)
Discussion started by: seyiisq
26 Replies

8. Shell Programming and Scripting

Script for V$flash_recovery_area_usage

Hello, on a daily / hourly basis I need need to check the size for the Flash Recovery Area (v$flash_recovery_area_usage) I was not in work yesterday and when I arrived today I checked the alert log only to find that the usage was 100%. This means the overnight backups will not run. I... (12 Replies)
Discussion started by: jnrpeardba
12 Replies

9. Shell Programming and Scripting

Copy file to SD card from internal flash.

Hi, At first I have to say that I know nothing about Linux :( But I am looking for solution how to copy one file from internal Lowrnace HDS flash memory. Lowrance HDS is Linux based device. Here is the link for firmware update files for this unit. At the end of main firmware file there... (62 Replies)
Discussion started by: PouchX
62 Replies

10. Solaris

Oracle DB, balancing flash with bulk disks

I'm working as sys admin on a db server that's currently serviced by 30x 15k disks and is getting about 3000-3500 iops. A consultant has suggested we can replace that with 10x 10k disks and 700g of flash. He has not performed any testing to determine the working set, growth patterns, etc... and I... (11 Replies)
Discussion started by: Nix_Lover
11 Replies

11. AIX

Please share the command to get flash doms on AIX

Hello, Please share the command to get flash doms on aix Best regards, Vishal (12 Replies)
Discussion started by: Vishal_dba
12 Replies

12. UNIX for Beginners Questions & Answers

Restore .dmg containing multiple partitions to bootable USB flash drive

I have a .dmg file which was created from a disk consisting of two partitions. When I mount the dmg both partitions pop up, so I know the imaging worked properly. One partition is HFS+ and the other is FAT32. So far, I've been unable to find a way to restore the dmg to a flash drive where both... (17 Replies)
Discussion started by: paulcristo
17 Replies