Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

clockctl(4) [netbsd man page]

CLOCKCTL(4)						   BSD Kernel Interfaces Manual 					       CLOCKCTL(4)

NAME
clockctl -- Clock subsystem user control SYNOPSIS
pseudo-device clockctl DESCRIPTION
The clockctl interface brings clock control to non-root users. Any user with write access to /dev/clockctl will be able to perform opera- tions such as settimeofday(2), clock_settime(2), adjtime(2), or ntp_adjtime(2), which are normally restricted to the super-user. Using the clockctl pseudo-device, it is possible to run daemons such as ntpd(8) as non-privileged users, thus reducing the security exposure if a com- promise is found in such a daemon. The clockctl pseudo-device driver provides an ioctl(2) call for each privileged clock-related system call. The system call stubs in C library will use the ioctl(2) on /dev/clockctl if the special file is present and accessible, or will revert to the plain super-user- restricted system call if the special file is not accessible. The following ioctl(2) calls are defined in <sys/clockctl.h>: CLOCKCTL_SETTIMEOFDAY This will run the settimeofday(2) system call. Argument should be a pointer to a struct clockctl_settimeofday: struct clockctl_settimeofday { const struct timeval *tv; const void *tzp; }; CLOCKCTL_CLOCK_SETTIME This will run the clock_settime(2) system call. Argument should be a pointer to a struct clockctl_clock_settime: struct clockctl_clock_settime { clockid_t clock_id; struct timespec *tp; }; CLOCKCTL_ADJTIME This will run the adjtime(2) system call. Argument should be a pointer to a struct clockctl_adjtime: struct clockctl_adjtime { const struct timeval *delta; struct timeval *olddelta; }; CLOCKCTL_NTP_ADJTIME This will run the ntp_adjtime(2) system call. Argument should be a pointer to a struct clockctl_ntp_adjtime: struct clockctl_ntp_adjtime { struct timex *tp; }; SEE ALSO
adjtime(2), clock_settime(2), ioctl(2), settimeofday(2) HISTORY
clockctl appeared in NetBSD 1.6. BSD
February 19, 2009 BSD

Check Out this Related Man Page

CLOCK_SETTIME(2)					      BSD System Calls Manual						  CLOCK_SETTIME(2)

NAME
clock_settime, clock_gettime, clock_getres -- clock and timer functions LIBRARY
Standard C Library (libc, -lc) SYNOPSIS
#include <time.h> int clock_settime(clockid_t clock_id, const struct timespec *tp); int clock_gettime(clockid_t clock_id, struct timespec *tp); int clock_getres(clockid_t clock_id, struct timespec *res); DESCRIPTION
The clock_settime() function sets the clock identified by clock_id to the absolute time specified by tp. If the time specified by tp is not a multiple of the resolution of the clock, tp is truncated to a multiple of the resolution. The clock_gettime() function stores the time of the clock identified by clock_id into the location specified by tp. The clock_getres() function stores the resolution of the clock identified by clock_id into the location specified by res, unless res is NULL. A clock_id of CLOCK_REALTIME identifies the realtime clock for the system. For this clock, the values specified by clock_settime() and obtained by clock_gettime() represent the amount of time (in seconds and nanoseconds) since 00:00 Universal Coordinated Time, January 1, 1970. A clock_id of CLOCK_MONOTONIC identifies a clock that increases at a steady rate (monotonically). This clock is not affected by calls to adjtime(2) and settimeofday(2) and will fail with an EINVAL error if it's the clock specified in a call to clock_settime(). The origin of the clock is unspecified. If the calling user is not the super-user, then the clock_settime() function in the standard C library will try to use the clockctl(4) device if present, thus making possible for non privileged users to set the system time. If clockctl(4) is not present or not accessible, then clock_settime() reverts to the clock_settime() system call, which is restricted to the super user. RETURN VALUES
A value of 0 is returned on success. Otherwise, a value of -1 is returned and errno is set to indicate the error. ERRORS
The clock_settime(), clock_gettime() and clock_getres() functions will fail if: [EINVAL] The clock_id argument does not specify a known clock. [ENOSYS] The function is not supported by this implementation. The clock_settime() function will fail if: [EINVAL] The tp argument is outside the range for the specified clock, clock_id. [EINVAL] The tp argument specified a nanosecond value less than zero of greater than or equal 1000 million. [EINVAL] The clock_id argument is a clock that can not be adjusted. [EPERM] The calling process does not have the appropriate privilege to set the specified clock, clock_id. The clock_gettime() function will fail if: [EFAULT] The tp argument specifies an address that is not a valid part of the process address space. SEE ALSO
ctime(3), time(3), clockctl(4) STANDARDS
The clock_settime(), clock_gettime() and clock_getres() functions conform to IEEE Std 1003.1b-1993 (``POSIX.1''). BSD
February 11, 1999 BSD
Man Page