Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

vm_map_check_protection(9) [freebsd man page]

VM_MAP_CHECK_PROTECTION(9)				   BSD Kernel Developer's Manual				VM_MAP_CHECK_PROTECTION(9)

NAME
vm_map_check_protection -- check memory protection for a vm_map SYNOPSIS
#include <sys/param.h> #include <vm/vm.h> #include <vm/vm_map.h> boolean_t vm_map_check_protection(vm_map_t map, vm_offset_t start, vm_offset_t end, vm_prot_t protection); DESCRIPTION
The vm_map_check_protection() function asserts that the target map allows the specified privilege protection over the entire address range from start to end. The region MUST be contiguous; no holes are allowed. IMPLEMENTATION NOTES
This code does not and SHOULD not check whether the contents of the region are accessible. For example, a small file may be mapped into an address space which is significantly larger in size. RETURN VALUES
The vm_map_check_protection() function returns TRUE if the privilege is allowed; if it is not allowed, or if any other error occurred, the value FALSE is returned. SEE ALSO
munmap(2), vm_map(9), vm_map_protect(9) AUTHORS
This manual page was written by Bruce M Simpson <bms@spc.org>. BSD
July 19, 2003 BSD

Check Out this Related Man Page

VM_MAP_CLEAN(9) 					   BSD Kernel Developer's Manual					   VM_MAP_CLEAN(9)

NAME
vm_map_clean -- push dirty pages to their pager SYNOPSIS
#include <sys/param.h> #include <vm/vm.h> #include <vm/vm_map.h> int vm_map_clean(vm_map_t map, vm_offset_t start, vm_offset_t end, boolean_t syncio, boolean_t invalidate); DESCRIPTION
The vm_map_clean() function forces any dirty cached pages in the range start to end within the map to be pushed to their underlying pager. If syncio is TRUE, dirty pages are written synchronously. If invalidate is TRUE, any cached pages are also freed. The range provided must be contiguous, it MUST NOT contain holes. The range provided MUST NOT contain any sub-map entries. IMPLEMENTATION NOTES
This routine holds the Giant lock to prevent multiple entry. RETURN VALUES
The vm_map_clean() function returns KERN_SUCCESS if successful. Otherwise, KERN_INVALID_ADDRESS will be returned if the function encountered a sub-map entry; KERN_INVALID_ARGUMENT will be returned if the function encountered a hole in the region provided, or if an entry could not be found for the given start address. SEE ALSO
vm_map(9) AUTHORS
This manual page was written by Bruce M Simpson <bms@spc.org>. BSD
July 19, 2003 BSD
Man Page