Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

vfs_mount(9) [freebsd man page]

VFS_MOUNT(9)						   BSD Kernel Developer's Manual					      VFS_MOUNT(9)

NAME
VFS_MOUNT -- mount a file system SYNOPSIS
#include <sys/param.h> #include <sys/mount.h> #include <sys/vnode.h> int VFS_MOUNT(struct mount *mp); DESCRIPTION
The VFS_MOUNT() macro mounts a file system into the system's namespace or updates the attributes of an already mounted file system. The arguments it expects are: mp Structure representing the file system. The VFS_MOUNT() macro is called both to mount new file systems and to change the attributes of an existing file system. If the MNT_UPDATE flag is set in mp->mnt_flag then the file system should update its internal state from the value of mp->mnt_flag. This can be used, for instance, to convert a read-only file system to read-write. It is also used by mountd(8) to update the NFS export information for the file system. If the MNT_UPDATE flag is not specified, then this is a newly mounted file system. The file system code should allocate and initialize any private data needed to represent the file system (it can use the mp->mnt_data field to store this information). SEE ALSO
VFS(9), vnode(9) AUTHORS
This manual page was written by Doug Rabson. BSD
May 23, 2009 BSD

Check Out this Related Man Page

VFS_FHTOVP(9)						   BSD Kernel Developer's Manual					     VFS_FHTOVP(9)

NAME
VFS_FHTOVP -- turn an NFS filehandle into a vnode SYNOPSIS
#include <sys/param.h> #include <sys/mount.h> #include <sys/vnode.h> int VFS_FHTOVP(struct mount *mp, struct fid *fhp, struct vnode **vpp); DESCRIPTION
The VFS_FHTOVP() macro is used by the NFS server to turn an NFS filehandle into a vnode. The arguments it expects are: mp The file system. fhp The filehandle to convert. vpp Return parameter for the new locked vnode. The contents of the filehandle are defined by the file system and are not examined by any other part of the system. It should contain enough information to uniquely identify a file within the file system as well as noticing when a file has been removed and the file system resources have been reused for a new file. For instance, UFS file system stores the inode number and inode generation counter in its filehandle. A call to VFS_FHTOVP() should generally be preceded by a call to VFS_CHECKEXP(9) to check if the file is accessible to the client. RETURN VALUES
The locked vnode for the file will be returned in *vpp. SEE ALSO
VFS(9), VFS_CHECKEXP(9), VOP_VPTOFH(9), vnode(9) AUTHORS
This manual page was written by Doug Rabson. BSD
January 4, 2010 BSD
Man Page