Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

vdrop(9) [freebsd man page]

VHOLD(9)						   BSD Kernel Developer's Manual						  VHOLD(9)

NAME
vhold, vdrop, vdropl -- acquire/release a hold on a vnode SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> void vhold(struct vnode *vp); void vholdl(struct vnode *vp); void vdrop(struct vnode *vp); void vdropl(struct vnode *vp); DESCRIPTION
The vhold() and vholdl() functions increment the v_holdcnt of the given vnode. If the vnode has already been added to the free list and is still referenced, it will be removed. The vdrop() and vdropl() functions decrement the v_holdcnt of the vnode. If the holdcount is less than or equal to zero prior to calling vdrop() or vdropl(), the system will panic. If the vnode is no longer referenced, it will be freed. vhold() and vdrop() lock the vnode interlock while vholdl() and vdropl() expect the interlock to already be held. SEE ALSO
vnode(9) AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca>. BSD
April 1, 2007 BSD

Check Out this Related Man Page

VRELE(9)						   BSD Kernel Developer's Manual						  VRELE(9)

NAME
vput, vrele, vunref -- decrement the use count for a vnode SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> void vput(struct vnode *vp); void vrele(struct vnode *vp); void vunref(struct vnode *vp); DESCRIPTION
Decrement the v_usecount field of a vnode. vp the vnode to decrement The vrele() function takes an unlocked vnode and returns with the vnode unlocked. The vput() function should be given a locked vnode as argument, the vnode is unlocked after the function returned. The vput() is opera- tionally equivalent to calling VOP_UNLOCK(9) followed by vrele(9), with less overhead. The vunref() function takes a locked vnode as argument, and returns with the vnode locked. Any code in the system which signified its use of a vnode by usecount should call one of the listed function to decrement use counter. If the v_usecount field of the non-doomed vnode reaches zero, then it will be inactivated and placed on the free list. Since the functions might need to call VOPs for the vnode, the Giant mutex should be conditionally locked around the call. The hold count for the vnode is always greater or equal to the usecount. Non-forced unmount fails when mount point owns a vnode that has non-zero usecount, see vflush(9). SEE ALSO
vget(9), vnode(9), vref(9), vrefcnt(9) AUTHORS
This manual page was written by Doug Rabson and Konstantin Belousov. BSD
November 20, 2010 BSD
Man Page

3 More Discussions You Might Find Interesting

1. Ubuntu

Date format in the files written by syslogd

Hi, Below is what i am seeing in /var/log/messages on ubuntu machine. 2013-01-14T18:29:39.319736+00:00 test01 ldap-mail: test1 Jan 14 18:29:39 test01 ldap-mail: test2 2013-01-14T18:29:39.320792+00:00 test01 ldap-mail: test3 Jan 14 18:29:39 test01 ldap-mail: test4But on other ubuntu... (29 Replies)
Discussion started by: prash358
29 Replies

2. Cybersecurity

When i start CSF i cant connect VPS or download any data into it It appears i cant connect Linux VP?

It appears i cant connect linux VPS server via SSH or i cant SCP any file to it and i cant wget any file TO it (from inside it) while CSF (Config Server Firewall, LFD is running. Just after isntall in default configuration and after changing TESTING mode to LIVE mode. Trying to wget & install... (1 Reply)
Discussion started by: postcd
1 Replies

3. UNIX for Beginners Questions & Answers

NTP synchronised problem in our Centos 7.6 node

Someone, please help on this issue:- Note : for security reason i didn't mention hostnames and ips. ============================================================================== # ntpstat unsynchronised polling server every 1024 s Ntpstat showing unsynchronised. ... (29 Replies)
Discussion started by: shanmugaraj
29 Replies