Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

resource_long_value(9) [freebsd man page]

RESOURCE_INT_VALUE(9)					   BSD Kernel Developer's Manual				     RESOURCE_INT_VALUE(9)

NAME
resource_int_value, resource_long_value, resource_string_value -- get a value from the hints mechanism SYNOPSIS
#include <sys/param.h> #include <sys/bus.h> int resource_int_value(const char *name, int unit, const char *resname, int *result); int resource_long_value(const char *name, int unit, const char *resname, long *result); int resource_string_value(const char *name, int unit, const char *resname, const char **result); DESCRIPTION
These functions fetch a value from the ``hints'' mechanism. The functions take the following arguments: name The name of the device to get the resource value from. unit The unit number of the device. -1 is special and is used for wildcard entries. resname The resource name. result A pointer to memory in which to store the resource value. RETURN VALUES
If successful, the functions return 0. Otherwise, a non-zero error code is returned. ERRORS
The functions will fail if: [ENOENT] The resource could not be found. [EFTYPE] Inappropriate resource type. SEE ALSO
device(9), driver(9) AUTHORS
This manual page was written by Warner Losh <imp@FreeBSD.org>. BSD
March 1, 2001 BSD

Check Out this Related Man Page

BUS_ACTIVATE_RESOURCE(9)				   BSD Kernel Developer's Manual				  BUS_ACTIVATE_RESOURCE(9)

NAME
bus_activate_resource, bus_deactivate_resource -- activate or deactivate a resource SYNOPSIS
#include <sys/param.h> #include <sys/bus.h> #include <machine/bus.h> #include <sys/rman.h> #include <machine/resource.h> int bus_activate_resource(device_t dev, int type, int rid, struct resource *r); int bus_deactivate_resource(device_t dev, int type, int rid, struct resource *r); DESCRIPTION
These functions activate or deactivate a previously allocated resource. In general, resources must be activated before they can be accessed by the driver so that the bus driver can map the resource into the devices space. The arguments are as follows: dev The device that requests ownership of the resource. Before allocation, the resource is owned by the parent bus. type The type of resource you want to allocate. It is one of: SYS_RES_IRQ for IRQs SYS_RES_DRQ for ISA DMA lines SYS_RES_IOPORT for I/O ports SYS_RES_MEMORY for I/O memory rid A pointer to a bus specific handle that identifies the resource being allocated. r A pointer to the struct resource returned by bus_alloc_resource(9). RETURN VALUES
Zero is returned on success, otherwise an error is returned. SEE ALSO
bus_alloc_resource(9), device(9), driver(9) AUTHORS
This manual page was written by Warner Losh <imp@FreeBSD.org>. BSD
March 28, 2003 BSD
Man Page