Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

pseudofs(9) [freebsd man page]

PSEUDOFS(9)						   BSD Kernel Developer's Manual					       PSEUDOFS(9)

NAME
pseudofs -- pseudo file system construction kit SYNOPSIS
#include <fs/pseudofs/pseudofs.h> DESCRIPTION
The pseudofs module offers an abstract API for pseudo-file systems such as procfs(5) and linprocfs(5). It takes care of all the hairy bits like interfacing with the VFS system, enforcing access control, keeping track of file numbers, and cloning files and directories that are process-specific. The consumer module, i.e., the module that implements the actual guts of the file system, needs only provide the directory structure (represented by a collection of structures declared and initialized by macros provided by pseudofs) and callbacks that report file attributes or write the actual file contents into sbufs. SEE ALSO
linprocfs(5), linsysfs(5), procfs(5), sbuf(9), vnode(9) HISTORY
The pseudofs module appeared in FreeBSD 5.0. AUTHORS
The pseudofs module and this manual page were written by Dag-Erling Smorgrav <des@FreeBSD.org>. BSD
April 20, 2007 BSD

Check Out this Related Man Page

KLD(3)							   BSD Library Functions Manual 						    KLD(3)

NAME
kld_isloaded, kld_load -- kld utility functions LIBRARY
System Utilities Library (libutil, -lutil) SYNOPSIS
#include <libutil.h> int kld_isloaded(const char *name); int kld_load(const char *name); DESCRIPTION
These functions facilitate loading kernel modules from userland applications. The kld_isloaded() function takes a name and returns a non-zero value if a module of that name is currently loaded. The name can be either the name of a module file (cpufreq.ko), the same name without the .ko extension (cpufreq), or the name of a module contained within that file (cpu/ichss). Only the latter will return correct results if the module is compiled into the kernel. The kld_load() function is a simple wrapper around the kldload(2) function. It returns zero if and only if the corresponding kldload() call succeeded or returned EEXIST (signifying that the requested module was already loaded). SEE ALSO
kldfirstmod(2), kldload(2), kldnext(2), kldstat(2), modfnext(2), modstat(2), kld(4) HISTORY
The kld_isloaded() and kld_load() functions first appeared in FreeBSD 6.3. AUTHORS
The kld_isloaded() and kld_load() functions and this manual page were written by Dag-Erling Smorgrav <des@FreeBSD.org>. BSD
February 18, 2006 BSD
Man Page