Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

extattr(9) [freebsd man page]

EXTATTR(9)						   BSD Kernel Developer's Manual						EXTATTR(9)

NAME
extattr -- virtual file system named extended attributes SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> #include <sys/extattr.h> DESCRIPTION
Named extended attributes allow additional meta-data to be associated with vnodes representing files and directories. The semantics of this additional data is that of a "name=value" pair, where a name may be defined or undefined, and if defined, associated with zero or more bytes of arbitrary binary data. Extended attribute names exist within a set of namespaces; each operation on an extended attribute is required to provide the namespace to which to operation refers. If the same name is present in multiple namespaces, the extended attributes associated with the names are stored and manipulated independently. The following two namespaces are defined universally, although individual file sys- tems may implement additional namespaces, or not implement these namespaces: EXTATTR_NAMESPACE_USER, EXTATTR_NAMESPACE_SYSTEM. The semantics of these attributes are intended to be as follows: user attribute data is protected according the normal discretionary and mandatory protec- tions associated with the data in the file or directory; system attribute data is protected such that appropriate privilege is required to directly access or manipulate these attributes. Reads of extended attribute data may return specific contiguous regions of the meta-data, in the style of VOP_READ(9), but writes will replace the entire current "value" associated with a given name. As there are a plethora of file systems with differing extended attributes, availability and functionality of these functions may be limited, and they should be used with awareness of the underlying semantics of the supporting file system. Authorization schemes for extended attribute data may also vary by file system, as well as maximum attribute size, and whether or not any or specific new attributes may be defined. Extended attributes are named using a null-terminated character string. Depending on underlying file system semantics, this name may or may not be case-sensitive. Appropriate vnode extended attribute calls are: VOP_GETEXTATTR(9), VOP_LISTEXTATTR(9), and VOP_SETEXTATTR(9). SEE ALSO
VFS(9), VFS_EXTATTRCTL(9), VOP_GETEXTATTR(9), VOP_LISTEXTATTR(9), VOP_SETEXTATTR(9) AUTHORS
This manual page was written by Robert Watson. BUGS
In addition, the interface does not provide a mechanism to retrieve the current set of available attributes; it has been suggested that pro- viding a NULL attribute name should cause a list of defined attributes for the passed file or directory, but this is not currently imple- mented. BSD
December 23, 1999 BSD

Check Out this Related Man Page

VOP_SETEXTATTR(9)					   BSD Kernel Developer's Manual					 VOP_SETEXTATTR(9)

NAME
VOP_SETEXTATTR -- set named extended attribute for a vnode SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> #include <sys/extattr.h> int VOP_SETEXTATTR(struct vnode *vp, int attrnamespace, const char *name, struct uio *uio, struct ucred *cred, struct thread *td); DESCRIPTION
This vnode call may be used to set specific named extended attribute for a file or directory. Its arguments are: vp The vnode of the file or directory. attrnamespace Integer constant indicating which extended attribute namespace the attribute name is present in. name Pointer to a null-terminated character string containing the attribute name. uio The location of the data to be read or written. cred The user credentials to use in authorizing the request. td The thread setting the extended attribute. The uio structure is used in a manner similar to the argument of the same name in VOP_WRITE(9). However, as extended attributes provide a strict "name=value" semantic, non-zero offsets will be rejected. The uio pointer may be NULL to indicate that the specified extended attribute should be deleted. The cred pointer may be NULL to indicate that access control checks are not to be performed, if possible. This cred setting might be used to allow the kernel to authorize extended attribute changes that the active process might not be permitted to make. Extended attribute semantics may vary by file system implementing the call. More information on extended attributes may be found in extattr(9). LOCKS
The vnode will be locked on entry and should remain locked on return. RETURN VALUES
If the extended attribute is successfully set, then zero is returned. Otherwise, an appropriate error code is returned. ERRORS
[EACCES] The the caller does not have the appropriate privilege. [ENXIO] The request was not valid in this file system for the specified vnode and attribute name. [ENOMEM] Insufficient memory available to fulfill request [EFAULT] The uio structure refers to an invalid userspace address. [EINVAL] The name, namespace, or uio argument is invalid. [EOPNOTSUPP] The file system does not support VOP_SETEXTATTR(). [ENOSPC] The file system is out of space. [EROFS] The file system is read-only. SEE ALSO
extattr(9), vnode(9), VOP_GETEXTATTR(9), VOP_LISTEXTATTR(9) AUTHORS
This manual page was written by Robert Watson. BSD
December 23, 1999 BSD
Man Page