Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

casueword32(9) [freebsd man page]

CASU(9) 						   BSD Kernel Developer's Manual						   CASU(9)

NAME
casueword, casueword32, casuword, casuword32 -- fetch, compare and store data from user-space SYNOPSIS
#include <sys/types.h> #include <sys/systm.h> int casueword(volatile u_long *base, u_long oldval, u_long *oldvalp, u_long newval); int casueword32(volatile uint32_t *base, uint32_t oldval, uint32_t *oldvalp, uint32_t newval); u_long casuword(volatile u_long *base, u_long oldval, u_long newval); uint32_t casuword32(volatile uint32_t *base, uint32_t oldval, uint32_t newval); DESCRIPTION
The casueword functions are designed to perform atomic compare-and-swap operation on the value in the usermode memory of the current process. The casueword routines reads the value from user memory with address base, and compare the value read with oldval. If the values are equal, newval is written to the *base. In case of casueword32() and casueword(), old value is stored into the (kernel-mode) variable pointed by *oldvalp. The userspace value must be naturally aligned. The callers of casuword() and casuword32() functions cannot distinguish between -1 read from userspace and function failure. RETURN VALUES
The casuword() and casuword32() functions return the data fetched or -1 on failure. The casueword() and casueword32() functions return 0 on success and -1 on failure. SEE ALSO
atomic(9), fetch(9), store(9) BSD
October 21, 2014 BSD

Check Out this Related Man Page

atomic_cas(9F)						   Kernel Functions for Drivers 					    atomic_cas(9F)

NAME
atomic_cas, atomic_cas_8, atomic_cas_uchar, atomic_cas_16, atomic_cas_ushort, atomic_cas_32, atomic_cas_uint, atomic_cas_ulong, atomic_cas_64, atomic_cas_ptr - atomic compare and swap operations SYNOPSIS
#include <sys/atomic.h> uint8_t atomic_cas_8(volatile uint8_t *target, uint8_t cmp, uint8_t newval); uchar_t atomic_cas_uchar(volatile uchar_t *target, uchar_t cmp, uchar_t newval); uint16_t atomic_cas_16(volatile uint16_t *target, uint16_t cmp, uint16_t newval); ushort_t atomic_cas_ushort(volatile ushort_t *target, ushort_t cmp, ushort_t newval); uint32_t atomic_cas_32(volatile uint32_t *target, uint32_t cmp, uint32_t newval); uint_t atomic_cas_uint(volatile uint_t *target, uint_t cmp, uint_t newval); ulong_t atomic_cas_ulong(volatile ulong_t *target, ulong_t cmp, ulong_t newval); uint64_t atomic_cas_64(volatile uint64_t *target, uint64_t cmp, uint64_t newval); void *atomic_cas_ptr(volatile void *target, void *cmp, void *newval); DESCRIPTION
These functions enable a compare and swap operation to occur atomically. The value stored in target is compared with cmp. If these values are equal, the value stored in target is replaced with newval. The old value stored in target is returned by the function whether or not the replacement occurred. RETURN VALUES
These functions return the old of *target. ERRORS
No errors are defined. CONTEXT
These functions can be called from user, interrupt, or kernel context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
atomic_add(9F), atomic_and(9F), atomic_bits(9F), atomic_dec(9F), atomic_inc(9F), atomic_or(9F), atomic_swap(9F), membar_ops(9F), attributes(5), atomic_ops(3C) SunOS 5.11 16 Jan 2006 atomic_cas(9F)
Man Page

13 More Discussions You Might Find Interesting

1. OS X (Apple)

Mac OS X: Based on UNIX - Solid As a Rock

See this threads: Page Not Found - Apple Open Source - Apple (0 Replies)
Discussion started by: Neo
0 Replies

2. Tips and Tutorials

The Whole Story on #! /usr/bin/ksh

Introduction Originally, we only had one shell on unix. When ran a command, the shell would attempt to invoke one of the exec() system calls on it. It the command was an executable, the exec would succeed and the command would run. If the exec() failed, the shell would not give up, instead it... (3 Replies)
Discussion started by: Perderabo
3 Replies

3. BSD

FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick

FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick nwbqBdghh6E The first hour of Marshall Kirk McKusick's course on FreeBSD kernel internals based on his book, The Design and Implementation of the FreeBSD Operating System. (0 Replies)
Discussion started by: Neo
0 Replies

4. Tips and Tutorials

Unix File Permissions

Introduction I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls: $ ls -ld /usr/bin /usr/bin/cat drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin -r-xr-xr-x 1 bin bin ... (6 Replies)
Discussion started by: Perderabo
6 Replies

5. Programming

Memory Leaks

Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram. main() { malloc(1gb) return(0) } The program above exits without freeing the memory. In this case will the 1 gb of heap memory be returned... (9 Replies)
Discussion started by: rupeshkp728
9 Replies

6. Shell Programming and Scripting

Scripts without shebang

I see lot of ad-hoc shell scripts in our servers which don't have a shebang at the beginning . Does this mean that it will run on any shell ? Is it a good practice to create scripts (even ad-hoc ones) without shebang ? (16 Replies)
Discussion started by: kraljic
16 Replies

7. Fedora

Is UNIX an open source OS ?

Hi everyone, I know the following questions are noobish questions but I am asking them because I am confused about the basics of history behind UNIX and LINUX. Ok onto business, my questions are-: Was/Is UNIX ever an open source operating system ? If UNIX was... (21 Replies)
Discussion started by: sreyan32
21 Replies

8. Web Development

A simple UNIXtime component in Vue.js

A shout out to Scott who gave me a helping hand to turn a simple sample Vue.js app I wrote yesterday into a Vue.js component: Vue.component("unix-time", { template: `<div class="time">{{unixtime}}</div>`, data() { return { unixtime: "" }; }, methods: { ... (1 Reply)
Discussion started by: Neo
1 Replies

9. Shell Programming and Scripting

Reason for no directory creation date

i read here that linux provides no way to determine when a directory was created. https://www.unix.com/shell-programming-and-scripting/157874-creation-date-directory.htmlI have a directory /home/andy/scripts that had a README file in it. That file says I put the script in that directory and... (3 Replies)
Discussion started by: drew77
3 Replies

10. Shell Programming and Scripting

Valid separator in time and date format

Hello. I can use any particular (stupid or not) format when using bash date command. Example : ~> date --date "now" '+%Y-%m-%d %H!%M!%S' 2019-06-03 12!55!33or ~> date --date "now" '+%Y£%m£%d %H¤%M¤%S' 2019£06£03 12¤57¤36 or ~> date --date "now" '+%Y-%m-%d %H-%M-%S' 2019-06-03 12-58-51 ... (4 Replies)
Discussion started by: jcdole
4 Replies

11. UNIX for Beginners Questions & Answers

UNIX Environment Setup - (Just starting!)

Morning All So, I am starting looking into the world of UNIX for a new job (luckily not my primary function!) and I am looking to get stared. Like anything I seem to learn best by trying things out first in an environment but I have a key question: Currently I use Oracle VirtualBox, can... (8 Replies)
Discussion started by: GophusMeau
8 Replies

12. Solaris

Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?

I've installed Slack 14.2 on /dev/sda1 (/dev/sda2 is swap) and FreeBSD 12 on /dev/sda3 and lilo is the boot manager. FreeBSD slices are as follows; / on /dev/ada0S3a, swap on /dev/ada0s3e, /var on /dev/ada0s3b, /tmp on /dev/ada0s3d and /usr on /dev/ada0s3f. I hesitate to install Solaris 10... (2 Replies)
Discussion started by: vectrum
2 Replies

13. Shell Programming and Scripting

Controlling user input

I'm trying to use a bash script for a psych experiment that involves listening to sound files and responding. If I have something like the code below, how can I make sure that a key press is assigned to RESPONSE only after the second echo statement? for i in 1 2 3; do echo "Ready?" sleep 2 ... (10 Replies)
Discussion started by: darwin_886
10 Replies