Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

boottime(9) [freebsd man page]

TIME(9) 						   BSD Kernel Developer's Manual						   TIME(9)

NAME
boottime, time_second, time_uptime -- system time variables SYNOPSIS
#include <sys/time.h> extern struct timeval boottime; extern time_t time_second; extern time_t time_uptime; DESCRIPTION
The boottime variable holds the system boot time. The time_second variable is the system's ``wall time'' clock to the second. The time_uptime variable is the number of seconds since boot. The bintime(9), getbintime(9), microtime(9), getmicrotime(9), nanotime(9), and getnanotime(9) functions can be used to get the current time more accurately and in an atomic manner. Similarly, the binuptime(9), getbinuptime(9), microuptime(9), getmicrouptime(9), nanouptime(9), and getnanouptime(9) functions can be used to get the time elapse since boot more accurately and in an atomic manner. The boottime variable may be read and written without special precautions. SEE ALSO
clock_settime(2), ntp_adjtime(2), settimeofday(2), bintime(9), binuptime(9), getbintime(9), getbinuptime(9), getmicrotime(9), getmicrouptime(9), getnanotime(9), getnanouptime(9), microtime(9), microuptime(9), nanotime(9), nanouptime(9) Poul-Henning Kamp, "Timecounters: Efficient and precise timekeeping in SMP kernels", Proceedings of EuroBSDCon 2002, Amsterdam, /usr/share/doc/papers/timecounter.ascii.gz. Marshall Kirk McKusick and George V. Neville-Neil, The Design and Implementation of the FreeBSD Operating System, Addison-Wesley, 57-61,65-66, July 2004. BSD
September 17, 2004 BSD

Check Out this Related Man Page

MICROTIME(9)						   BSD Kernel Developer's Manual					      MICROTIME(9)

NAME
bintime, getbintime, microtime, getmicrotime, nanotime, getnanotime -- get the current time SYNOPSIS
#include <sys/time.h> void bintime(struct bintime *bt); void getbintime(struct bintime *bt); void microtime(struct timeval *tv); void getmicrotime(struct timeval *tv); void nanotime(struct timespec *ts); void getnanotime(struct timespec *tsp); DESCRIPTION
The bintime() and getbintime() functions store the system time as a struct bintime at the addresses specified by bt. The microtime() and getmicrotime() functions perform the same utility, but record the time as a struct timeval instead. Similarly the nanotime() and getnanotime() functions store the time as a struct timespec. The structures are described in timeval(3). The bintime(), microtime(), and nanotime() functions always query the timecounter to return the current time as precisely as possible. Whereas getbintime(), getmicrotime(), and getnanotime() functions are abstractions which return a less precise, but faster to obtain, time. The intent of the getbintime(), getmicrotime(), and getnanotime() functions is to enforce the user's preference for timer accuracy versus execution time. They should be used where a precision of 1/HZ (e.g., 10 msec on a 100HZ machine, see hz(9)) is acceptable or where perfor- mance is priority. The system realtime clock is guaranteed to be monotonically increasing at all times. As such, all calls to these functions are guaranteed to return a system time greater than or equal to the system time returned in any previous calls. Comparable functions exist to retrieve the time elapsed since boot; see microuptime(9). SEE ALSO
settimeofday(2), bintime_add(9), inittodr(9), time_second(9), tvtohz(9) CODE REFERENCES
The implementation of the microtime() family of functions is in sys/kern/kern_tc.c as a part of the timecounter(9) framework. The implementation of the time counter sources used by the timecounter(9) is machine dependent, hence its location in the source code tree varies from architecture to architecture. AUTHORS
This manual page was written by Jeremy Cooper and Kelly Yancey <kbyanc@posi.net>. BUGS
Despite the guarantee that the system realtime clock will always be monotonically increasing, it is always possible for the system clock to be manually reset by the system administrator to any date. BSD
June 8, 2010 BSD
Man Page