Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

services_mkdb(8) [freebsd man page]

SERVICES_MKDB(8)					    BSD System Manager's Manual 					  SERVICES_MKDB(8)

NAME
services_mkdb -- generate the services database SYNOPSIS
services_mkdb [-b | -l] [-q] [-o database] [file] services_mkdb -u [file] DESCRIPTION
The services_mkdb utility creates a db(3) database for the specified file. If no file is specified, then /etc/services is used. The data- base is installed into /var/db/services.db. The file must be in the correct format (see services(5)). The options are as follows: -b Use big-endian byte order for database metadata. -l Use little-endian byte order for database metadata. -o database Put the output databases in the named file. -q Do not warn about duplicate services. -u Print the services file to stdout, omitting duplicate entries and comments. The databases are used by the C library services routines (see The -b and -l flags are mutually exclusive. The default byte ordering is the current host order. getservent(3)). FILES
/var/db/services.db The current services database. /var/db/services.db.tmp A temporary file. /etc/services The current services file. EXIT STATUS
The services_mkdb utility exits 0 on success, and >0 if an error occurs. SEE ALSO
db(3), getservent(3), services(5) BUGS
Because services_mkdb guarantees not to install a partial destination file it must build a temporary file in the same file system and if suc- cessful use rename(2) to install over the destination file. If services_mkdb fails it will leave the previous version of the destination file intact. BSD
April 4, 2010 BSD

Check Out this Related Man Page

GETSERVENT(3)						     Linux Programmer's Manual						     GETSERVENT(3)

NAME
getservent, getservbyname, getservbyport, setservent, endservent - get service entry SYNOPSIS
#include <netdb.h> struct servent *getservent(void); struct servent *getservbyname(const char *name, const char *proto); struct servent *getservbyport(int port, const char *proto); void setservent(int stayopen); void endservent(void); DESCRIPTION
The getservent() function reads the next line from the file /etc/services and returns a structure servent containing the broken out fields from the line. The /etc/services file is opened if necessary. The getservbyname() function returns a servent structure for the line from /etc/services that matches the service name using protocol proto. If proto is NULL, any protocol will be matched. The getservbyport() function returns a servent structure for the line that matches the port port given in network byte order using protocol proto. If proto is NULL, any protocol will be matched. The setservent() function opens and rewinds the /etc/services file. If stayopen is true (1), then the file will not be closed between calls to getservbyname() and getservbyport(). The endservent() function closes /etc/services. The servent structure is defined in <netdb.h> as follows: struct servent { char *s_name; /* official service name */ char **s_aliases; /* alias list */ int s_port; /* port number */ char *s_proto; /* protocol to use */ } The members of the servent structure are: s_name The official name of the service. s_aliases A zero terminated list of alternative names for the service. s_port The port number for the service given in network byte order. s_proto The name of the protocol to use with this service. RETURN VALUE
The getservent(), getservbyname() and getservbyport() functions return the servent structure, or a NULL pointer if an error occurs or the end of the file is reached. FILES
/etc/services services database file CONFORMING TO
BSD 4.3 SEE ALSO
getprotoent(3), getnetent(3), services(5) BSD
2001-07-25 GETSERVENT(3)
Man Page