Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

memcontrol(8) [freebsd man page]

MEMCONTROL(8)						    BSD System Manager's Manual 					     MEMCONTROL(8)

NAME
memcontrol -- control system cache behaviour with respect to memory SYNOPSIS
memcontrol list [-a] memcontrol set -b base -l length -o owner attribute memcontrol clear -o owner memcontrol clear -b base -l length DESCRIPTION
A number of supported system architectures allow the behaviour of the CPU cache to be programmed to behave differently depending on the region being written. The memcontrol utility provides an interface to this facility, allowing CPU cache behavior to be altered for ranges of system physical mem- ory. These ranges are typically power-of-2 aligned and sized, however the specific rules governing their layout vary between architectures. The memcontrol utility does not attempt to enforce these rules, however the system will reject any attempt to set an illegal combination. list List range slots. -a List all range slots, even those that are inactive. set Set memory range attributes. -b base Memory range base address. -l length Length of memory range in bytes, power of 2. -o owner Text identifier for this setting (7 char max). attribute Attributes applied to this range; combinations of force, uncacheable, write-combine, write-through, write-back, and write-protect. clear Clear memory range attributes. Ranges may be cleared by owner or by base/length combination. To clear based on ownership: -o owner All ranges with this owner will be cleared. To clear based on the base/length combination: -b base Memory range base address. -l length Length of memory range in bytes, power of 2. Base and length must exactly match an existing range. SEE ALSO
mem(4) BSD
September 15, 2002 BSD

Check Out this Related Man Page

I386_GET_MTRR(2)					   BSD/i386 System Calls Manual 					  I386_GET_MTRR(2)

NAME
i386_get_mtrr, i386_set_mtrr -- access Memory Type Range Registers LIBRARY
i386 Architecture Library (libi386, -li386) SYNOPSIS
#include <sys/types.h> #include <machine/sysarch.h> #include <machine/mtrr.h> int i386_get_mtrr(struct mtrr *mtrrp, int *n); int i386_set_mtrr(struct mtrr *mtrrp, int *n); DESCRIPTION
These functions provide an interface to the MTRR registers found on 686-class processors for controlling processor access to memory ranges. This is most useful for accessing devices such as video accelerators on pci(4) and agp(4) buses. For example, enabling write-combining allows bus-write transfers to be combined into a larger transfer before bursting over the bus. This can increase performance of write opera- tions 2.5 times or more. mtrrp is a pointer to one or more mtrr structures, as described below. The n argument is a pointer to an integer containing the number of structures pointed to by mtrrp. For i386_set_mtrr() the integer pointed to by n will be updated to reflect the actual number of MTRRs suc- cessfully set. For i386_get_mtrr() no more than n structures will be copied out, and the integer value pointed to by n will be updated to reflect the actual number of valid structures retrieved. A NULL argument to mtrrp will result in just the number of MTRRs available being returned in the integer pointed to by n. The argument mtrrp has the following structure: struct mtrr { uint64_t base; uint64_t len; uint8_t type; int flags; pid_t owner; }; The location of the mapping is described by its physical base address base and length len. Valid values for type are: MTRR_TYPE_UC uncached memory MTRR_TYPE_WC use write-combining MTRR_TYPE_WT use write-through caching MTRR_TYPE_WP write-protected memory MTRR_TYPE_WB use write-back caching Valid values for flags are: MTRR_PRIVATE own range, reset the MTRR when the current process exits MTRR_FIXED use fixed range MTRR MTRR_VALID entry is valid The owner member is the PID of the user process which claims the mapping. It is only valid if MTRR_PRIVATE is set in flags. To clear/reset MTRRs, use a flags field without MTRR_VALID set. RETURN VALUES
Upon successful completion zero is returned, otherwise -1 is returned on failure, and the global variable errno is set to indicate the error. The integer value pointed to by n will contain the number of successfully processed mtrr structures in both cases. ERRORS
[ENOSYS] The currently running kernel or CPU has no MTRR support. [EINVAL] The currently running kernel has no MTRR support, or one of the mtrr structures pointed to by mtrrp is invalid. [EBUSY] No unused MTRRs are available. HISTORY
The i386_get_mtrr() and i386_set_mtrr() functions appeared in NetBSD 1.6. BSD
November 10, 2001 BSD
Man Page