Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

iasl(8) [freebsd man page]

IASL(8) 						    BSD System Manager's Manual 						   IASL(8)

NAME
iasl -- Intel ACPI compiler/decompiler SYNOPSIS
iasl [-2cefghl] [-b type] [-d file] [-dc file] [-hc] [-hr] [-i type] [-ln] [-ls] [-oa] [-of] [-oi] [-on] [-ot] [-p prefix] [-s type] [-t type] [-vi] [-vo] [-vr] [-vs] [-x level] [-w level] input-file DESCRIPTION
The iasl utility is a compiler/decompiler for ACPI Source Language (ASL) and ACPI Machine Language (AML). Major features of iasl include: o Full support for the ACPI 3.0b Specification including ASL grammar elements and operators. o Extensive compiler syntax and semantic error checking, especially in the area of control methods. This reduces the number of errors that are not discovered until the AML code is actually interpreted (i.e., the compile-time error checking reduces the number of run-time errors). o Multiple types of output files, including formatted listing files with intermixed source, several types of AML files, and error messages. OPTIONS
-2 Emit ACPI 2.0 compatible ASL code. -b p|t|b Create compiler debug/trace file (*.txt). Types: Parse/Tree/Both. -c Parse only, no output generation. -d file Disassemble AML to ASL source code file (*.dsl). -dc file Disassemble AML and immediately compile it. (Obtain DSDT from current system if no input file.) -e Generate External() statements for unresolved symbols. -f Ignore errors, force creation of AML output file(s). -g Get ACPI tables and write to files (*.dat). -h Additional help and compiler debug options. -hc Display operators allowed in constant expressions. -hr Display ACPI reserved method names. -i a|c Create assembler or C include file (*.inc or *.h). -l Create mixed listing file (ASL source and AML) (*.lst). -ln Create namespace file (*.nsp). -ls Create combined source file (expanded includes) (*.src). -oa Disable all optimizations (compatibility mode). -of Disable constant folding. -oi Disable integer optimization to Zero/One/Ones. -on Disable named reference string optimization. -ot Display compile times. -p prefix Specify filename prefix for all output files (including .aml). -s a|c Create AML in assembler or C source file (*.asm or *.c). -t a|c Create AML in assembler or C hex table (*.hex). -vi Less verbose errors and warnings for use with IDEs. -vo Enable optimization comments. -vr Disable remarks. -vs Disable signon. -x level Set debug level for trace output. -w level Set warning level. SEE ALSO
acpi(4), acpidump(8) HISTORY
The iasl utility is provided with Intel ACPI-CA. It first appeared in FreeBSD 5.2. AUTHORS
The iasl utility was written by Intel. This manual page was written by Nate Lawson. BSD
May 20, 2008 BSD

Check Out this Related Man Page

IASL(1) 						      General Commands Manual							   IASL(1)

NAME
iasl - ACPI Source Language compiler/decompiler SYNOPSIS
iasl [options] [input file] DESCRIPTION
This manual page documents briefly the iasl command. The option list is taken from the iasl interactive help. iasl is an ASL compiler and decompiler. OPTIONS
General Output -p <prefix> Specify filename prefix for all output files (including .aml) -vi Less verbose errors and warnings for use with IDEs -vo Enable optimization comments -vr Disable remarks -vs Disable signon AML Output Files -s<a|c> Create AML in assembler or C source file (*.asm or *.c) -i<a|c> Create assembler or C include file (*.inc or *.h) -t<a|c> Create AML in assembler or C hex table (*.hex) AML Code Generation -oa Disable all optimizations (compatibility mode) -of Disable constant folding -oi Disable integer optimization to Zero/One/Ones -on Disable named reference string optimization -r<Revision> Override table header Revision (1-255) Listings -l Create mixed listing file (ASL source and AML) (*.lst) -ln Create namespace file (*.nsp) -ls Create combined source file (expanded includes) (*.src) AML Disassembler -d [file] Disassemble AML to ASL source code file (*.dsl) -dc [file] Disassemble AML and immediately compile it (Obtain DSDT from current system if no input file) -e Generate External() statements for unresolved symbols -g Get ACPI tables and write to files (*.dat) Miscellaneous -a Verify source file is entirely ASCII text (0x00-0x7F) Help -h Additional help and compiler debug options -hc Display operators allowed in constant expressions -hr Display ACPI reserved method names AUTHOR
iasl was written by Robert Moore <robert.moore@intel.com>. This manual page was written by Mattia Dongili <malattia@debian.org>, for the Debian project (but may be used by others). October 14, 2005 IASL(1)
Man Page