Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

atf(7) [freebsd man page]

ATF(7)						       BSD Miscellaneous Information Manual						    ATF(7)

NAME
ATF -- introduction to the Automated Testing Framework DESCRIPTION
The Automated Testing Framework (ATF) is a collection of libraries to implement test programs in a variety of languages. These libraries all offer similar functionality and any test program written with them exposes a consistent user interface. Test programs using the ATF libraries rely on a separate runtime engine to execute them in a deterministic fashion. The runtime engine iso- lates the test programs from the rest of the system and ensures some common side-effects are cleaned up. The runtime engine is also respon- sible for gathering the results of all tests and composing reports. The current runtime of choice is Kyua, described in kyua(1). If your operating systems distributes ATF, it should also provide an introductory tests(7) manual page. You are encouraged to read it now. The rest of this manual page serves as a cross-reference to all the other documentation shipped with ATF. Language bindings atf-c(3) C programming interface. atf-c++(3) C++ programming interface. atf-sh(3) sh(1) programming interface. Miscellaneous pages atf-test-case(4) Generic description of test cases, independent of the language they are implemented in. atf-test-program(1) Common interface provided by the test programs written using the ATF libraries. SEE ALSO
kyua(1), tests(7) HISTORY
ATF started as a Google Summer of Code 2007 project mentored by The NetBSD Foundation. Its original goal was to provide a testing framework for the NetBSD operating system, but it grew as an independent project because the framework itself did not need to be tied to a specific operating system. Originally, ATF shipped the collection of libraries described in this manual page as well as a runtime engine. The runtime engine has since been replaced by Kyua and the old tools were removed in 0.20, which shipped in early 2014. As of late 2014, both FreeBSD and NetBSD ship ATF in their base systems and provide extensive test suites based on it. For more details on historical changes, refer to: /usr/share/doc/atf/NEWS AUTHORS
For more details on the people that made ATF possible, refer to: /usr/share/doc/atf/AUTHORS BSD
September 14, 2014 BSD

Check Out this Related Man Page

ATF-CHECK(1)						    BSD General Commands Manual 					      ATF-CHECK(1)

NAME
atf-check -- executes a command and analyzes its results SYNOPSIS
atf-check [-s qual:value] [-o action:arg ...] [-e action:arg ...] [-x] command atf-check -h DESCRIPTION
atf-check executes a given command and analyzes its results, including exit code, stdout and stderr. In the first synopsis form, atf-check will execute the provided command and apply checks specified by arguments. By default it will act as if it was run with -s exit:0 -o empty -e empty. Multiple checks for the same output channel are allowed and, if specified, their results will be combined as a logical and (meaning that the output must match all the provided checks). In the second synopsis form, atf-check will print information about all supported options and their purpose. The following options are available: -h Shows a short summary of all available options and their purpose. -s qual:value Analyzes termination status. Must be one of: exit:<value> checks that the program exited cleanly and that its exit status is equal to value. The exit code can be omit- ted altogether, in which case any clean exit is accepted. ignore ignores the exit check. signal:<value> checks that the program exited due to a signal and that the signal that terminated it is value. The signal can be specified both as a number or as a name, or it can also be omitted altogether, in which case any signal is accepted. Most of these checkers can be prefixed by the 'not-' string, which effectively reverses the check. -o action:arg Analyzes standard output. Must be one of: empty checks that stdout is empty ignore ignores stdout file:<path> compares stdout with given file inline:<value> compares stdout with inline value match:<regexp> looks for a regular expression in stdout save:<path> saves stdout to given file Most of these checkers can be prefixed by the 'not-' string, which effectively reverses the check. -e action:arg Analyzes standard error (syntax identical to above) -x Executes command as a shell command line, executing it with the system shell defined by ATF_SHELL in atf-config(1). You should avoid using this flag if at all possible to prevent shell quoting issues. EXIT STATUS
atf-check exits 0 on success, and other (unspecified) value on failure. EXAMPLES
# Exit code 0, nothing on stdout/stderr atf-check 'true' # Typical usage if failure is expected atf-check -s not-exit:0 'false' # Checking stdout/stderr echo foobar >expout atf-check -o file:expout -e inline:"xx yy " 'echo foobar ; printf "xx yy " >&2' # Checking for a crash atf-check -s signal:sigsegv my_program # Combined checks atf-check -o match:foo -o not-match:bar echo foo baz SEE ALSO
atf-config(1), atf(7) BSD
June 27, 2010 BSD
Man Page