Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ntb(4) [freebsd man page]

NTB(4)							   BSD Kernel Interfaces Manual 						    NTB(4)

NAME
ntb, ntb_hw, if_ntb -- Intel(R) Non-Transparent Bridge driver SYNOPSIS
To compile this driver into your kernel, place the following lines in your kernel configuration file: device ntb_hw device if_ntb Or, to load the driver as a module at boot, place the following line in loader.conf(5): if_ntb_load="YES" DESCRIPTION
The ntb driver provides support for the Non-Transparent Bridge (NTB) in the Intel S1200, Xeon E3 and Xeon E5 processor families. The NTB allows you to connect two computer systems using a PCI-e link if they have the correct equipment and connectors. CONFIGURATION
The NTB memory windows need to be configured by the BIOS. If your BIOS allows you to set their size, you should set the size of both memory windows to 1 MiB. This needs to be done on both systems. Each system needs to have a different IP address assigned. The MAC address is randomly generated. Also for maximum performance, the MTU should be set to 16 kiB. This can be done by adding the line below to rc.conf(5): ifconfig_ntb0="inet 192.168.1.10 netmask 255.255.255.0 mtu 16384" And on the second system : ifconfig_ntb0="inet 192.168.1.11 netmask 255.255.255.0 mtu 16384" If you are using the UDP protocol, you may want to increase the net.inet.udp.maxdgram sysctl(8) variable. SEE ALSO
rc.conf(5), sysctl(8) AUTHORS
The ntb driver was developed by Intel and originally written by Carl Delsey <carl@FreeBSD.org>. BUGS
If the driver is unloaded, it cannot be reloaded without a system reboot. The network support is limited. It isn't fully configurable yet. It also isn't integrated into netgraph(4) or bpf(4). NTB to Root Port mode is not yet supported. There is no way to protect your system from malicious behavior on the other system once the link is brought up. Anyone with root or kernel access on the other system can read or write to any location on your system. In other words, only connect two systems that completely trust each other. BSD
Apr 11, 2013 BSD

Check Out this Related Man Page

CARP(4) 						   BSD Kernel Interfaces Manual 						   CARP(4)

NAME
carp -- Common Address Redundancy Protocol SYNOPSIS
pseudo-device carp [count] DESCRIPTION
The carp interface is a pseudo-device which implements and controls the CARP protocol. carp allows multiple hosts on the same local network to share a set of IP addresses. Its primary purpose is to ensure that these addresses are always available, but in some configurations carp can also provide load balancing functionality. A carp interface can be created at runtime using the ifconfig carpN create command. To use carp, the administrator needs to configure at minimum a common virtual host ID and virtual host IP address on each machine which is to take part in the virtual group. Additional parameters can also be set on a per-interface basis: advbase and advskew, which are used to con- trol how frequently the host sends advertisements when it is the master for a virtual host, and pass which is used to authenticate carp advertisements. Finally carpdev is used to specify which interface the carp device attaches to. If unspecified, the kernel attempts to set carpdev by looking for another interface with the same subnet. These configurations can be done using ifconfig(8), or through the SIOCSVH ioctl. Additionally, there are a number of global parameters which can be set using sysctl(8): net.inet.carp.allow Accept incoming carp packets. Enabled by default. net.inet.carp.preempt Allow virtual hosts to preempt each other. It is also used to failover carp interfaces as a group. When the option is enabled and one of the carp enabled physical interfaces goes down, advskew is changed to 240 on all carp interfaces. See also the first example. Disabled by default. net.inet.carp.log Log bad carp packets. Disabled by default. net.inet.carp.arpbalance Balance local traffic using ARP. Disabled by default. EXAMPLES
For firewalls and routers with multiple interfaces, it is desirable to failover all of the carp interfaces together, when one of the physical interfaces goes down. This is achieved by the preempt option. Enable it on both host A and B: # sysctl -w net.inet.carp.preempt=1 Assume that host A is the preferred master and 192.168.1.x/24 is configured on one physical interface and 192.168.2.y/24 on another. This is the setup for host A: # ifconfig carp0 create # ifconfig carp0 vhid 1 pass mekmitasdigoat 192.168.1.1 netmask 255.255.255.0 # ifconfig carp1 create # ifconfig carp1 vhid 2 pass mekmitasdigoat 192.168.2.1/24 netmask 255.255.255.0 The setup for host B is identical, but it has a higher advskew: # ifconfig carp0 create # ifconfig carp0 vhid 1 advskew 100 pass mekmitasdigoat 192.168.1.1 netmask 255.255.255.0 # ifconfig carp1 create # ifconfig carp1 vhid 2 advskew 100 pass mekmitasdigoat 192.168.2.1 netmask 255.255.255.0 Because of the preempt option, when one of the physical interfaces of host A fails, advskew is adjusted to 240 on all its carp interfaces. This will cause host B to preempt on both interfaces instead of just the failed one. In order to set up an ARP balanced virtual host, it is necessary to configure one virtual host for each physical host which would respond to ARP requests and thus handle the traffic. In the following example, two virtual hosts are configured on two hosts to provide balancing and failover for the IP address 192.168.1.10. First the carp interfaces on Host A are configured. The advskew of 100 on the second virtual host means that its advertisements will be sent out slightly less frequently. # ifconfig carp0 create # ifconfig carp0 vhid 1 pass mekmitasdigoat 192.168.1.10 netmask 255.255.255.0 # ifconfig carp1 create # ifconfig carp1 vhid 2 advskew 100 pass mekmitasdigoat 192.168.1.10 netmask 255.255.255.0 The configuration for host B is identical, except the skew is on virtual host 1 rather than virtual host 2. # ifconfig carp0 create # ifconfig carp0 vhid 1 advskew 100 pass mekmitasdigoat 192.168.1.10 netmask 255.255.255.0 # ifconfig carp1 create # ifconfig carp1 vhid 2 pass mekmitasdigoat 192.168.1.10 netmask 255.255.255.0 Finally, the ARP balancing feature must be enabled on both hosts: # sysctl -w net.inet.carp.arpbalance=1 When the hosts receive an ARP request for 192.168.1.10, the source IP address of the request is used to compute which virtual host should answer the request. The host which is master of the selected virtual host will reply to the request, the other(s) will ignore it. This way, locally connected systems will receive different ARP replies and subsequent IP traffic will be balanced among the hosts. If one of the hosts fails, the other will take over the virtual MAC address, and begin answering ARP requests on its behalf. Note: ARP balancing only works on the local network segment. It cannot balance traffic that crosses a router, because the router itself will always be balanced to the same virtual host. SEE ALSO
netstat(1), sysctl(3), arp(4), arp(8), ifconfig(8), sysctl(8) HISTORY
The carp device first appeared in OpenBSD 3.5. BSD
October 16, 2003 BSD
Man Page