Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ng_echo(4) [freebsd man page]

NG_ECHO(4)						   BSD Kernel Interfaces Manual 						NG_ECHO(4)

NAME
ng_echo -- netgraph echo node type SYNOPSIS
#include <netgraph/ng_echo.h> DESCRIPTION
The echo node type reflects all data and control messages back to the sender. This node type is used for testing and debugging. HOOKS
A echo node accepts any request to connect, regardless of the hook name, as long as the name is unique. CONTROL MESSAGES
This node type supports only the generic control messages. Any other control messages are reflected back to the sender. SHUTDOWN
This node shuts down upon receipt of a NGM_SHUTDOWN control message, or when all hooks have been disconnected. SEE ALSO
netgraph(4), ng_hole(4), ngctl(8) HISTORY
The ng_echo node type was implemented in FreeBSD 4.0. AUTHORS
Julian Elischer <julian@FreeBSD.org> BSD
January 19, 1999 BSD

Check Out this Related Man Page

NG_ETHER_ECHO(4)					   BSD Kernel Interfaces Manual 					  NG_ETHER_ECHO(4)

NAME
ng_ether_echo -- netgraph ether_echo node type SYNOPSIS
#include <netgraph/ng_ether_echo.h> DESCRIPTION
The ether_echo node type reflects all data and control messages back to the sender. It assumes (and does not check) that the packet is an ethernet frame, and swaps the source and destination addresses before echoing it. This node type is used for testing and debugging. HOOKS
A ether_echo node accepts any request to connect, regardless of the hook name, as long as the name is unique. CONTROL MESSAGES
This node type supports only the generic control messages. Any other control messages are reflected back to the sender. SHUTDOWN
This node shuts down upon receipt of a NGM_SHUTDOWN control message, or when all hooks have been disconnected. SEE ALSO
netgraph(4), ng_hole(4), ng_echo(4), ng_ether(4), ngctl(8) HISTORY
The ng_ether_echo node type was implemented in FreeBSD 8.0. AUTHORS
Julian Elischer <julian@FreeBSD.org> BSD
December 24, 2008 BSD
Man Page

15 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

how can I write "$" using echo ?

hi . I'm trying to write the following line in csh : echo "abc=$(AA)" >> $filename and I get "variable syntax" ... what's the problem ? How can I write $ ? not in the meanning of a file pointer . thanks , Eyal Hegamal . (7 Replies)
Discussion started by: azran
7 Replies

2. Shell Programming and Scripting

how to print backslah using echo

how to print 3 backslah using Unix AIX, i have try in my fedora and AIX,both give dirrent output for same echo statment test.sh sed -e 's/\(\)/\\\1/g' -e 's/\$?/\\$?/g' -e 's/\$#/\\$#/g' -e 's/^/echo "/g' -e 's/$/ "/g' xMNBDF070 > xMNBDF070_test xMNBDF070 sed -e "s/'/\\\'/g" -e... (8 Replies)
Discussion started by: mani_um
8 Replies

3. Shell Programming and Scripting

help in using echo

hello , I want the output as Let the script is as below first=second second=third My requirement is I want the output as fourth through $first i am doing echo ""`echo "echo $"$""$first""""`"" its giving echo $second but i want ouput as third (9 Replies)
Discussion started by: pradeepreddy
9 Replies

4. UNIX for Dummies Questions & Answers

Putting echoed text into a new file

Hi, I've set up a script so that a user answers questions, and then these answers come back onto the screen accompanied by text that I've echoed. Is there a way of putting this into a new file? Thanks (7 Replies)
Discussion started by: likelylad
7 Replies

5. Shell Programming and Scripting

Using echo in AWK

Hello, I have written the script below to extract specific data from a text file and then use the data extracted as parameters for another shell script call 'loto_tsim'. Everytime I run my script it complains about the 'echo' line. Am I missing something? I have spent hours and still cannot solve... (10 Replies)
Discussion started by: jermaine4ever
10 Replies

6. Shell Programming and Scripting

Using Echo

Hi All, Need help in resoving the issue . Can anyone let me know how to get fix length using unix shellscript. For Ex: echo "NUMBER OF RECORDS "${NO_OF_ROWS}"\nFILE CREATION DATE&TIME "${PROD_DT}" output should be : NUMBER OF RECORDS 2546 CREATIN DATE&TIME 2009-12-01 Each... (14 Replies)
Discussion started by: Samtel
14 Replies

7. Shell Programming and Scripting

Errors while using echo

Hi I am new to shell scripting. I am using a shell script to create a SQL script file and then call it as well. The created SQL script file has calls to 2 other sql script file, as well as compile and execute a procedure. all this works fine. I am getting some simple errors. My code is as below ... (8 Replies)
Discussion started by: man_expo
8 Replies

8. UNIX for Dummies Questions & Answers

How to bold, blink, italicise words using echo command?

Hello Everyone. I am trying to bold, blink, italicise words using echo command. As per the research I did, it says to use the following escape code to get the effects. #!/bin/bash clear echo -e "\033 However when I am compiling I am not getting the desired effect. Can anyone... (7 Replies)
Discussion started by: grc
7 Replies

9. Shell Programming and Scripting

\n in ksh using echo & printf

#!/usr/bin/ksh var1="Hi World" var2="Morning" var3=$(echo "$var1" \n "$var2") echo $var3 var3=$(printf "$var1 \n $var2") echo $var3 Output Any way to get in my $var3 ? (7 Replies)
Discussion started by: dahlia84
7 Replies

10. UNIX for Dummies Questions & Answers

Using echo

I am using echo as follows echo -n "arg_path = echo $0:h = $arg_path" which produces arg_path = echo /home/chrisd/tatsh/trunk/hstmy/bin/csh = /home/chrisd/tatsh/trunk/hstmy/bin/csh However I want to get arg_path = echo $0:h = /home/chrisd/tatsh/trunk/hstmy/bin/csh (6 Replies)
Discussion started by: kristinu
6 Replies

11. Shell Programming and Scripting

Combining echo and awk

i have a script that has many lines similar to: echo $var | awk -F"--" '{print $2}' as you can see, two commands are being run here. echo and awk. id like to combine this into one awk statement. i tried: awk -F"--" "BEGIN{print $var; print $2}" but i get error messages. (10 Replies)
Discussion started by: SkySmart
10 Replies

12. Shell Programming and Scripting

Using echo, grep and wc and outputing to text file

My current line command is as follows: echo -n "text: " ; grep "blah text" ../dir1/filename | wc -l The output to the screen is as needed, but how do I print to a text file? (9 Replies)
Discussion started by: ncwxpanther
9 Replies

13. Shell Programming and Scripting

Formatting echo o/p

Hi Team, Need a small help. I want to format my echo o/p. let say echo " helo helo helo helo helo helo helo helo helo helo helo helo helo helo helo helo helo helo helo " I want o/p to be displayed in below format helo helo helo helo helo helo helo helo helo helo helo helo... (6 Replies)
Discussion started by: gvkumar25
6 Replies

14. UNIX for Advanced & Expert Users

A hexdumper using echo only...

Hi guys... Sometime ago I said I was going to attempt an Android project. I got my phone for XMAS and after installing a terminal program I realised how limited the command line is. I do NOT intend to __root__ the phone at this point but I can read and write to certain folders. The biggest... (14 Replies)
Discussion started by: wisecracker
14 Replies

15. Shell Programming and Scripting

Replacing echo with print

Hi everyone, I'm executing a shell script and one of the commands is creating a file with text via echo. However, if the text within echo has "\t" or similar, it automatically translates it into a TAB character, same goes for other special characters. I know that if I put another "\"... (7 Replies)
Discussion started by: demmel
7 Replies