|Linux & Unix Commands - Search Man Pages
MFI(4) BSD Kernel Interfaces Manual MFI(4)
mfi -- LSI MegaRAID SAS driver
To compile this driver into the kernel, place the following lines in your kernel configura-
Alternatively, to load the driver as a module at boot time, place the following line in
This driver is for LSI's next generation PCI Express SAS RAID controllers. Access to RAID
arrays (logical disks) from this driver is provided via /dev/mfid? device nodes. A simple
management interface is also provided on a per-controller basis via the /dev/mfi? device
The mfi name is derived from the phrase "MegaRAID Firmware Interface", which is substan-
tially different than the old "MegaRAID" interface and thus requires a new driver. Older
SCSI and SATA MegaRAID cards are supported by amr(4) and will not work with this driver.
Two sysctls are provided to tune the mfi driver's behavior when a request is made to remove
a mounted volume. By default the driver will disallow any requests to remove a mounted vol-
ume. If the sysctl dev.mfi.%d.delete_busy_volumes is set to 1, then the driver will allow
mounted volumes to be removed.
A tunable is provided to adjust the mfi driver's behaviour when attaching to a card. By
default the driver will attach to all known cards with high probe priority. If the tunable
hw.mfi.mrsas_enable is set to 1, then the driver will reduce its probe priority to allow
mrsas to attach to the card instead of mfi.
The mfi driver supports the following hardware:
o LSI MegaRAID SAS 1078
o LSI MegaRAID SAS 8408E
o LSI MegaRAID SAS 8480E
o LSI MegaRAID SAS 9240
o LSI MegaRAID SAS 9260
o Dell PERC5
o Dell PERC6
o IBM ServeRAID M1015 SAS/SATA
o IBM ServeRAID M1115 SAS/SATA
o IBM ServeRAID M5015 SAS/SATA
o IBM ServeRAID M5110 SAS/SATA
o IBM ServeRAID-MR10i
o Intel RAID Controller SRCSAS18E
o Intel RAID Controller SROMBSAS18E
/dev/mfid? array/logical disk interface
/dev/mfi? management interface
mfid%d: Unable to delete busy device An attempt was made to remove a mounted volume.
amr(4), pci(4), mfiutil(8)
The mfi driver first appeared in FreeBSD 6.1.
The mfi driver and this manual page were written by Scott Long <scottl@FreeBSD.org>.
The driver does not support big-endian architectures at this time.
BSD July 15, 2013 BSD
All times are GMT -4. The time now is 12:15 PM.