|Linux & Unix Commands - Search Man Pages
ACPI_ASUS(4) BSD Kernel Interfaces Manual ACPI_ASUS(4)
acpi_asus -- Asus Laptop Extras
To compile this driver into the kernel, place the following line in your kernel configura-
Alternatively, to load the driver as a module at boot time, place the following line in
The acpi_asus driver provides support for the extra ACPI-controlled gadgets, such as hotkeys
and leds, found on recent Asus (and Medion) laptops. It allows one to use the sysctl(8)
interface to manipulate the brightness of the LCD panel and the display output state.
Hotkey events are passed to devd(8) for easy handling in userspace with the default configu-
ration in /etc/devd/asus.conf.
Currently, the following Asus laptops are fully supported:
Additionally, acpi_asus also supports the Asus-compatible ATK0100 interface found in Samsung
The following sysctls are currently implemented:
Makes the LCD backlight brighter or dimmer (higher values are brighter).
Turns the LCD backlight on or off.
Sets the active display to use according to a bitwise OR of the following:
0 No display
Some models also support video switching via the generic acpi_video(4) driver. Most
models do not, however.
Defaults for these variables can be set in sysctl.conf(5), which is parsed at boot-time.
acpi(4), acpi_asus_wmi(4), acpi_video(4), sysctl.conf(5), sysctl(8)
The acpi4asus Project, http://sourceforge.net/projects/acpi4asus/.
The acpi_asus driver first appeared in FreeBSD 5.3.
The acpi_asus driver and this manual page were written by Philip Paeps <philip@FreeBSD.org>.
Inspiration came from the acpi4asus project started by Julien Lerouge which maintains a
driver implementing this functionality in the Linux kernel.
BSD February 8, 2010 BSD
All times are GMT -4. The time now is 05:48 PM.