Unix/Linux Go Back    


Homework & Coursework Questions Students must use and complete the template provided. If you don't, your post may be deleted! Special homework rules apply here.

NFS service not started in Redhat Cluster

Homework & Coursework Questions


Closed    
 
Thread Tools Search this Thread Display Modes
    #1  
Old Unix and Linux 09-09-2015
nitinredekar nitinredekar is offline
Registered User
 
Join Date: Sep 2015
Last Activity: 11 September 2015, 7:46 AM EDT
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
NFS service not started in Redhat Cluster

Hi All,

Need your help to resolve below error in cluter.


Code:
Sep  9 05:37:30 node2 rgmanager[2804]: Starting disabled service service:Prod_Service
Sep  9 05:37:30 node2 rgmanager[7545]: [lvm] HA LVM:  Improper setup detected
Sep  9 05:37:30 node2 rgmanager[7567]: [lvm] * initrd image needs to be newer than lvm.conf
Sep  9 05:37:30 node2 rgmanager[7607]: [lvm] Activating vg_prod-nfs/lv_Prod-nfs
Sep  9 05:37:30 node2 rgmanager[7637]: [lvm] Making resilient : lvchange -ay vg_prod-nfs/lv_Prod-nfs
Sep  9 05:37:30 node2 rgmanager[7662]: [lvm] Resilient command: lvchange -ay vg_prod-nfs/lv_Prod-nfs --config devices{filter=["a|/dev/sdb|","r|.*|"]}
Sep  9 05:37:31 node2 rgmanager[7738]: [fs] mounting /dev/dm-0 on /PROD-HOME
Sep  9 05:37:31 node2 kernel: EXT4-fs (dm-0): mounted filesystem with ordered data mode. Opts: 
Sep  9 05:37:31 node2 rgmanager[7822]: [nfsclient] No export path specified.
Sep  9 05:37:31 node2 rgmanager[2804]: start on nfsclient "Prod-client" returned 2 (invalid argument(s))
Sep  9 05:37:31 node2 rgmanager[2804]: #68: Failed to start service:Prod_Service; return value: 1
Sep  9 05:37:31 node2 rgmanager[2804]: Stopping service service:Prod_Service
Sep  9 05:37:31 node2 rgmanager[7892]: [nfsclient] No export path specified.
Sep  9 05:37:31 node2 rgmanager[2804]: stop on nfsclient "Prod-client" returned 2 (invalid argument(s))
Sep  9 05:37:31 node2 rgmanager[7962]: [fs] unmounting /PROD-HOME
Sep  9 05:37:31 node2 rgmanager[8017]: [lvm] HA LVM:  Improper setup detected
Sep  9 05:37:31 node2 rgmanager[8039]: [lvm] * initrd image needs to be newer than lvm.conf
Sep  9 05:37:31 node2 rgmanager[8072]: [lvm] Deactivating vg_prod-nfs/lv_Prod-nfs
Sep  9 05:37:31 node2 rgmanager[8094]: [lvm] Making resilient : lvchange -an vg_prod-nfs/lv_Prod-nfs
Sep  9 05:37:31 node2 rgmanager[8119]: [lvm] Resilient command: lvchange -an vg_prod-nfs/lv_Prod-nfs --config devices{filter=["a|/dev/sdb|","r|.*|"]}
Sep  9 05:37:31 node2 rgmanager[8149]: [lvm] Removing ownership tag (node2.xyz.com) from vg_prod-nfs/lv_Prod-nfs
Sep  9 05:37:31 node2 rgmanager[2804]: #12: RG service:Prod_Service failed to stop; intervention required
Sep  9 05:37:31 node2 rgmanager[2804]: Service service:Prod_Service is failed
Sep  9 05:37:31 node2 rgmanager[2804]: #13: Service service:Prod_Service failed to stop cleanly

I am not sure where to define nfs path.

This setup i am trying on Centos 6.5.

Last edited by nitinredekar; 09-10-2015 at 10:19 AM..
Sponsored Links
    #2  
Old Unix and Linux 09-09-2015
agent.kgb agent.kgb is offline
Registered User
 
Join Date: Feb 2015
Last Activity: 17 January 2017, 6:46 PM EST
Location: basement, Lubyanka, Moscow
Posts: 323
Thanks: 8
Thanked 95 Times in 84 Posts
NFS Server configuration:
https://access.redhat.com/documentat...verconfig.html
Sponsored Links
    #3  
Old Unix and Linux 09-09-2015
Corona688 Corona688 is offline Forum Staff  
Mead Rotor
 
Join Date: Aug 2005
Last Activity: 17 January 2017, 5:46 PM EST
Location: Saskatchewan
Posts: 21,742
Thanks: 1,024
Thanked 4,022 Times in 3,735 Posts
To keep the forums high quality for all users, please take the time to format your posts correctly.

First of all, use Code Tags when you post any code or data samples so others can easily read your code. You can easily do this by highlighting your code and then clicking on the # in the editing menu. (You can also type code tags [code] and [/code] by hand.)



Second, avoid adding color or different fonts and font size to your posts. Selective use of color to highlight a single word or phrase can be useful at times, but using color, in general, makes the forums harder to read, especially bright colors like red.

Third, be careful when you cut-and-paste, edit any odd characters and make sure all links are working property.

Thank You.

The UNIX and Linux Forums
    #4  
Old Unix and Linux 09-10-2015
nitinredekar nitinredekar is offline
Registered User
 
Join Date: Sep 2015
Last Activity: 11 September 2015, 7:46 AM EDT
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
below is the cluster conf file.

Code:
<?xml version="1.0"?>
<cluster config_version="19" name="prime-cluster">
	<clusternodes>
		<clusternode name="node1.xyz.com" nodeid="1"/>
		<clusternode name="node2.xyz.com" nodeid="2"/>
	</clusternodes>
	<cman expected_votes="1" transport="udpu" two_node="1"/>
	<rm>
		<failoverdomains>
			<failoverdomain name="Prime-Fail" nofailback="1">
				<failoverdomainnode name="node1.xyz.com"/>
				<failoverdomainnode name="node2.xyz.com"/>
			</failoverdomain>
		</failoverdomains>
		<resources>
			<ip address="10.1.24.249" sleeptime="10"/>
			<nfsexport name="Prod-export"/>
			<lvm lv_name="lv_Prod-nfs" name="Prod_HA_LVM" vg_name="vg_prod-nfs"/>
			<fs device="/dev/vg_prod-nfs/lv_Prod-nfs" force_unmount="1" fsid="12345" fstype="ext4" mountpoint="/PROD-HOME" name="FS-Prod" options="defaults"/>
			<nfsclient allow_recover="1" name="Prod-client" options="rw,sync,no_root_squash" target="*"/>
		</resources>
		<service domain="Prime-Fail" name="Prod_Service" recovery="relocate">
			<ip ref="10.1.24.249"/>
			<lvm ref="Prod_HA_LVM">
				<fs ref="FS-Prod"/>
			</lvm>
			<nfsexport ref="Prod-export">
				<nfsclient ref="Prod-client"/>
			</nfsexport>
		</service>
	</rm>
</cluster>

Pls let me know whats wrong ...
Sponsored Links
Closed

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Linux More UNIX and Linux Forum Topics You Might Find Helpful
Thread Thread Starter Forum Replies Last Post
Redhat 6.2 cluster karmellove Red Hat 1 11-28-2012 08:16 AM
Redhat cluster arumon Red Hat 3 04-05-2010 04:05 AM
Samba smb not started on Redhat Enterprise lamoul Red Hat 1 01-26-2010 06:01 PM
All dependicies of nfs service is online but nfs is offline spandhan Solaris 9 09-10-2009 12:03 PM
Unable to start cluster service in redhat 5 santhoshb Red Hat 0 08-07-2007 08:19 AM



All times are GMT -4. The time now is 04:00 AM.