Sun Blade 2500 - boot fails | Unix Linux Forums | BSD

  Go Back    


BSD BSD, sometimes called Berkeley Unix, is a Unix operating system developed by the Computer Systems Research Group of the UC Berkeley.

Sun Blade 2500 - boot fails

BSD


Closed Thread    
 
Thread Tools Search this Thread Display Modes
    #1  
Old 03-24-2013
LeFrettchen LeFrettchen is offline
Registered User
 
Join Date: Mar 2013
Last Activity: 25 January 2014, 7:21 PM EST
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Sun [Solved] Sun Blade 2500 - boot fails

Hi everybody.

I received my eBayed Sun Blade 2500, 4 Gb RAM, 1xUSIIIi@1,28GHz, diskless.
Diskless, but I wanted to try to boot, just to see.
A friend let me use his IDE CD-RW drive.

I burned a OpenBSD SPARC64 install CD with my mac, no error detected during the burn.

The OBP banner displays some tips : ethernet address, 4 Gb RAM ok, Open Boot 4.17.1

I must wait a few seconds, during the net boot, which logically fails, no tftp server installed.

I tried a cdrom boot, but it also failed :

Code:
ok>boot cdrom

Boot device: /pci@1e,600000/ide@d/cdrom@2,0:f File and args:
Bad magic number in disk label.
Can't open disk label package

Can't open boot device

I saw my friend stated his drive in Slave mode, I tried Master mode, no way :

Code:
ok>boot cdrom

Boot device: /pci@1e,600000/ide@d/cdrom@2,0:f File and args:

Can't open boot device

But the CD-Drive seems to be ok :

Code:
ok>devalias cdrom
cdrom        /pci@1e,600000/ide@d/cdrom@2,0:f

I only have one old CD-RW, so I can't try another today.
Tomorrow, I'll buy new ones, and try again.

Last edited by LeFrettchen; 03-26-2013 at 07:08 PM..
Sponsored Links
    #2  
Old 03-25-2013
DukeNuke2's Avatar
DukeNuke2 DukeNuke2 is offline Forum Staff  
Soulman
 
Join Date: Jul 2006
Last Activity: 24 October 2014, 5:39 PM EDT
Location: Berlin, Germany
Posts: 5,414
Thanks: 55
Thanked 231 Times in 224 Posts
try to install solaris on the machine and see if that works...
Sponsored Links
    #3  
Old 03-25-2013
fpmurphy's Avatar
fpmurphy fpmurphy is offline Forum Staff  
who?
 
Join Date: Dec 2003
Last Activity: 22 October 2014, 12:44 PM EDT
Location: /dev/ph
Posts: 4,822
Thanks: 64
Thanked 429 Times in 398 Posts
If I recall correctly, Sun SPARC systems are finicky about the make and model of DVD or CDROM that you use.
    #4  
Old 03-25-2013
LeFrettchen LeFrettchen is offline
Registered User
 
Join Date: Mar 2013
Last Activity: 25 January 2014, 7:21 PM EST
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Well, I encountered many troubles while burning the CD : my old CD-RW disc is a 13 or 15 years old CD.
It's a really old one, but the only one I found in my stuff.
So, I think it's the source of the mess.

I bought new CDs to burn, and I'll try just after the dinner.

---------- Post updated at 05:20 PM ---------- Previous update was at 04:01 PM ----------

I was right : my CD-RW disc was the source of the trouble.

I tried with a new disc, the machine recognized the CD and launched the CD boot.

Now, another trouble.
OBP tells me :

Code:
Following devices are disabled :
ide

I found a solution on a forum, I'll try it tomorrow, my wife went to bed and the Blade is a noisy machine.

The tip I found :

Code:
To fix, send a stop-A (Ctrl-A F in minicom), you should have the OBP ok prompt :
{1} ok .asr
{1} asr-clear
{1} reset-all

Sponsored Links
    #5  
Old 03-26-2013
LeFrettchen LeFrettchen is offline
Registered User
 
Join Date: Mar 2013
Last Activity: 25 January 2014, 7:21 PM EST
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Worked fine.

The .asr command returns :

Code:
ok>.asr
ide                   Disabled by FWDIAGS
                      OBDIAG failure

The asr-clear command doesn't return anything on screen, and with the reset-all command, the machine reboots, and yeeeees, cdrom boot works !

Of course, I cannot install anything, diskless Blade.
But boot works, and I can access a minimal shell.

But the OBP screen is awful, black on white, and really slow.
Sponsored Links
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

More UNIX and Linux Forum Topics You Might Find Helpful
Thread Thread Starter Forum Replies Last Post
SUN BLADE T6340 - which OS ? PtaQ UNIX for Dummies Questions & Answers 4 10-13-2012 03:35 PM
Sun Blade 150 will not boot off harddrive after install of solaris 10 chucky Solaris 4 03-15-2012 03:44 PM
Sun Blade 150 wont boot off cdrom chucky Solaris 3 03-14-2012 06:10 PM
Sun Blade 150 not a Sun? apmcd47 Solaris 1 01-19-2012 08:51 AM
Anyone has problems with new Blade 2500???? facaizhu Solaris 4 01-11-2006 06:43 PM



All times are GMT -4. The time now is 12:14 AM.