Need help finding missing drivers | Unix Linux Forums | AIX

  Go Back    


AIX AIX is IBM's industry-leading UNIX operating system that meets the demands of applications that businesses rely upon in today's marketplace.

Need help finding missing drivers

AIX


Tags
solved

Closed Thread    
 
Thread Tools Search this Thread Display Modes
    #1  
Old 02-07-2013
acascianelli's Avatar
acascianelli acascianelli is offline
Registered User
 
Join Date: Mar 2008
Last Activity: 27 March 2014, 7:48 AM EDT
Location: Macomb, MI
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
[Solved] Need help finding missing drivers

I'm in the process of migrating a system to some newer hardware (Power 5 to Power 7). I've done these migrations in the past, and have not had any problems. But this system does not see the new network controllers on the Power 7 system. The system was running AIX 5.3 before, I've upgraded it to AIX 6.1 TL6 which is the latest supported TL that the software I need to run supports.

When I run a cfgmgr, I get a message saying that the following packages are missing. I'm assuming this is what is stopping the network cards from being detected. But I cannot find these packages anywhere.


Code:
devices.pciex.ethernet
devices.pciex.pciex14e4.1657.1014.420.1
devices.pciex.e414571614102004
devices.pciex.14102004
devices.pciex.pciex14e4.1657.1
devices.pciex.e4145716
devices.pciex.pciexclass.020000
devices.pciex.pciexclass.000200

Can someone point me in the right direction on where I can find and install these packages?

Thanks.

Last edited by acascianelli; 02-19-2013 at 12:33 PM.. Reason: SOLVED
Sponsored Links
    #2  
Old 02-08-2013
-=XrAy=- -=XrAy=- is offline
Registered User
 
Join Date: Oct 2012
Last Activity: 30 July 2014, 4:42 PM EDT
Location: D:\Rheinland-Pfalz\Koblenz
Posts: 92
Thanks: 4
Thanked 19 Times in 17 Posts
Just an idea:

smitty devices ->
Install/Configure Devices Added After IPL ->
INPUT device / directory for software ->

"AIX 6.1 TL6 Installation Media (LPP Source, /dev/cd...)"

P.S. Have you checked the minimum software requirement (TL) for your Power7 hardware?

Example:

Code:
Announcment_p770_ENUS110-025.pdf
Site 2: Key prerequisites:
AIX 6.1 with the 6100-03 Technology Level and Service Pack 5, or later, available June 25, 2010


Last edited by -=XrAy=-; 02-08-2013 at 03:21 AM..
Sponsored Links
    #3  
Old 02-11-2013
MichaelFelt MichaelFelt is offline
Registered User
 
Join Date: Nov 2012
Last Activity: 11 December 2013, 7:33 AM EST
Location: on the road for work; home is private time
Posts: 311
Thanks: 6
Thanked 75 Times in 71 Posts
Just to be sure I understand.

  1. Was running AIX 5.3 on Power7 hardware and the drivers were available.
  2. After migration upgrade to AIX 6.1 TL6 the drivers "disappeared".
I suspect (read am guessing) you migrated using a AIX 6.1 DVD that predates Power7. I am guessing this because "probably" all support for these devices came with Power7 (correct me if I am wrong here - Model and Type will help as well).

Without a driver I am not sure what lscfg -v will be able to say but the output from that command for these devices might give some clues, at least for a google search.

The more common problem is that this concerns OLD adapters that no longer are supported by AIX 6.1 (as an example I ran into this way back when when updating from AIX 4.1 to AIX 4.2 (or to 4.3) when AIX dropped support for the 2G tape drives. AIX could see them, and reported that it did not have a driver (as your error message does) - but there was not a driver available.
And I have seen it also with old generation graphic adapters.

Assuming there are drivers - if you can install a DVD

Code:
cfgmgr -i /dev/cd0

otherwise nfs mount an lpp_source, or download a complete TL6 with latest SP to /some/directory and then run

Code:
cfgmgr -i /some/directory

If the drivers are there, cfgmgr will find and install them. Note: one of the characteristics of a complete TL plus SP download is that it contains ALL drivers!
If you go to fixcentral and download be sure to say the level of the install DVD as base (not your current level) to get "installable" (i.e. so called .I filesets) rather than "update" (.U).
FYI: yet another way is to use SUMA ( smit suma ). I prefer this whenever possible, but not everyone can direct attach (to internet) an AIX system - i.e., firewall rules prohibit it.

In short, if there are drivers - get them into /some/directory , then

Code:
cfgmgr -i /some/directory

    #4  
Old 02-11-2013
acascianelli's Avatar
acascianelli acascianelli is offline
Registered User
 
Join Date: Mar 2008
Last Activity: 27 March 2014, 7:48 AM EDT
Location: Macomb, MI
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
I found the problem.

The 4 port NIC that was ordered with the Power7 is a new card and I don't meet the minimum software requirements for it to work on AIX. I was a few SP's behind when I was running 5.3, and and entire TL behind when running 6.1. I have new installation/upgrade media on the way and should be "fixing" the problem.
Sponsored Links
    #5  
Old 02-11-2013
bakunin bakunin is offline Forum Staff  
Bughunter Extraordinaire
 
Join Date: May 2005
Last Activity: 31 July 2014, 8:54 AM EDT
Location: In the leftmost byte of /dev/kmem
Posts: 4,130
Thanks: 44
Thanked 775 Times in 610 Posts
Thanks for the update. We always appreciate getting follow-ups to know if our suggestions worked and how the problem was finally solved. Please tell us if the new TL solved your problem and i will change the thread's title accordingly.

bakunin
Sponsored Links
    #6  
Old 02-19-2013
acascianelli's Avatar
acascianelli acascianelli is offline
Registered User
 
Join Date: Mar 2008
Last Activity: 27 March 2014, 7:48 AM EDT
Location: Macomb, MI
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
Finally got around to loading a newer version of AIX on this system, 6.1 TL7 SP6. That did the trick.

Moderator's Comments:
deit by bakunin: adapted thread title

Last edited by bakunin; 02-19-2013 at 06:35 PM..
Sponsored Links
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

More UNIX and Linux Forum Topics You Might Find Helpful
Thread Thread Starter Forum Replies Last Post
[solved] Group sysadmin missing Junaid Subhani Solaris 1 10-25-2012 09:54 AM
[Solved] missing date in unix rabindratech Shell Programming and Scripting 10 10-02-2012 10:41 AM
Finding missing tags kristinu Shell Programming and Scripting 1 04-29-2011 04:31 PM
[SOLVED] mysql.sock is missing.. senkerth UNIX for Dummies Questions & Answers 19 12-20-2010 06:06 AM
Finding which file is missing SAMZ UNIX for Advanced & Expert Users 10 06-25-2008 08:30 AM



All times are GMT -4. The time now is 11:44 PM.