Sponsored Content
Full Discussion: ps -ef
Top Forums UNIX for Dummies Questions & Answers ps -ef Post 81411 by jim mcnamara on Friday 19th of August 2005 10:05:18 AM
Old 08-19-2005
pgrep is a GNU linux utility - if you do not have it then use
Code:
ps -ef | grep -q dhcpd
if [ $? -eq 0 ] ; then
  echo "dhcpd running"
else
  echo "dhcpd not running"
fi

 
DHCLIENT.LEASES(5)					      BSD File Formats Manual						DHCLIENT.LEASES(5)

NAME
dhclient.leases -- DHCP client lease database DESCRIPTION
The Internet Software Consortium DHCP client keeps a persistent database of leases that it has acquired that are still valid. The database is a free-form ASCII file containing one valid declaration per lease. If more than one declaration appears for a given lease, the last one in the file is used. The file is written as a log, so this is not an unusual occurrence. The lease file is named dhclient.leases.IFNAME, where IFNAME represents the network interface the DHCP client acquired the lease on. For example, if dhclient(8) is configured for the em0 network device, the lease file will be named dhclient.leases.em0. The format of the lease declarations is described in dhclient.conf(5). FILES
/var/db/dhclient.leases.IFNAME Current lease file. SEE ALSO
dhclient.conf(5), dhcp-options(5), dhcpd.conf(5), dhclient(8), dhcpd(8) RFC 2132, RFC 2131. AUTHORS
The dhclient(8) utility was written by Ted Lemon <mellon@vix.com> under a contract with Vixie Labs. The current implementation was reworked by Henning Brauer <henning@openbsd.org>. BSD
January 1, 1997 BSD
All times are GMT -4. The time now is 03:23 AM.
Unix & Linux Forums Content Copyright 1993-2022. All Rights Reserved.
Privacy Policy